новое событие
Информационный поток
Задания вакансии материалы разработки сообщения форума
mich76
Приватное сообщение

Переписать ВПФ УПД

Задание в категории песочница
17 |  0
30 апреля 2020 в 19:37:16 (1 год 38 недель 4 дня 21 час назад)
10650
Текст задания
После обновления 1С (Аренда и управление недвижимостью для "1С:Бухгалтерия 8", редакция 3.0 (3.0.64.54/3.3.3.122) ) перестала работать внешняя печатная форма УПД. Ошибка при печати из группового формирования документов: Поле объекта не обнаружено (МенеджерПечати).
В данной ВПФ УПД отсутствуют команды печати - менеджер печати и параметры печати.

Процедура, которая выкидывает ошибку:

Процедура ВыполнитьПечатьНаКлиентеЗавершение(МассивДокументов, ДополнительныеПараметры) Экспорт

ЗаполнитьСостоянияДокументов();

КомандаПечати = ДополнительныеПараметры.КомандаПечати;
НаПринтер = ДополнительныеПараметры.НаПринтер;

Если КомандаПечати.МенеджерПечати = "Документ.СчетФактураВыданный" Тогда
НастройкиПечати = УчетНДСВызовСервера.ПолучитьНастройкиПечатиСчетовФактур(МассивДокументов);
КомандаПечати.Идентификатор = НастройкиПечати.СписокМакетов;
МассивДокументов = НастройкиПечати.СчетаФактуры;
ИначеЕсли КомандаПечати.МенеджерПечати = "Обработка.ПечатьУПД" Тогда
НастройкиПечати = УчетНДСВызовСервера.ПолучитьНастройкиПечатиУниверсальныхПередаточныхДокументов(МассивДокументов);
КомандаПечати.Идентификатор = НастройкиПечати.СписокМакетов;
МассивДокументов = НастройкиПечати.УниверсальныеПередаточныеДокументы;
КонецЕсли;



Если КомандаПечати.Внешняя Тогда
ДополнительныеОтчетыИОбработкиКлиент.ВыполнитьОткрытиеПечатнойФормы(КомандаПечати, ЭтаФорма, МассивДокументов);
ИначеЕсли НаПринтер Тогда
УправлениеПечатьюКлиент.ВыполнитьКомандуПечатиНаПринтер(КомандаПечати.МенеджерПечати, КомандаПечати.Идентификатор, МассивДокументов, КомандаПечати.ПараметрыПечати);
Иначе
УправлениеПечатьюКлиент.ВыполнитьКомандуПечати(КомандаПечати.МенеджерПечати, КомандаПечати.Идентификатор, МассивДокументов, ЭтаФорма, КомандаПечати.ПараметрыПечати);
КонецЕсли;

КонецПроцедуры
0
Выбранные исполнители
Отклики