Информационный поток
Задания вакансии материалы разработки сообщения форума
pavel
Приватное сообщение

Помочь с движениями по регистрам

Екатеринбург(Россия)
11 | 0
3 октября 2016 в 15:46:53(8 недель 5 дней 19 часов назад)
650
Текст задания
БГУ 2.0
Документ Меню-требование.
Пример конструкции приведен ниже.
Я в регистр добавил пару реквизитов.
Мне нужно, чтобы при проведении документа эти реквизиты заполнялись.
Кто может проконсультировать что куда подставить?


// Формирует движения по регистру "РасходПродуктов" по таблице источника данных "Списание продуктов питания".
//
Процедура ОтразитьСписаниеПродуктовПитанияВРегистреРасходПродуктов(ДокументОбъект, ТаблицаСписаниеПродуктовПитания) Экспорт

Если ДокументОбъект.ЭтоНовый() Тогда
Возврат; // Просмотр проводок в новом документе.
КонецЕсли;

РасходПродуктов = ДокументОбъект.Движения.РасходПродуктов;
РасходПродуктов.Очистить();
РасходПродуктов.Записывать = Истина;

Отбор = Новый Структура("ВидУчета", "БУ");
СтрокиСписанияПродуктовБУ = ТаблицаСписаниеПродуктовПитания.НайтиСтроки(Отбор);

Для Каждого СтрокаСписания Из СтрокиСписанияПродуктовБУ Цикл

Движение = РасходПродуктов.Добавить();
Движение.Период = ДокументОбъект.Дата;
Движение.Организация = ДокументОбъект.Организация;
ЗаполнитьЗначенияСвойств(Движение, СтрокаСписания,
"ИФО,КФО,КатегорияДовольствующихся,Номенклатура");

Движение.Количество = СтрокаСписания.Количество;
Движение.Сумма = СтрокаСписания.Стоимость;
Движение.КоличествоДовольствующихся = СтрокаСписания.КоличествоДовольствующихся;

КонецЦикла;

КонецПроцедуры
0
Отклики (1)
Чтобы добавить свое предложение, Вам необходимо авторизоваться либо зарегистрироваться.
    На главную страницу ≡ к списку заданий 1С