Информационный поток
Задания вакансии материалы разработки сообщения форума
Ольга92
Приватное сообщение
Новый заказчик

доработка внешнего файла обработки (выгружает из iiko в 1с)

Задача добавлена через сайт партнера Форум 1С
22.10.1992(24 года)
17 сентября 2015 в 20:35:12(1 год 11 недель 6 дней 6 часов назад)
Текст задания
требуется доработка внешнего файла обработки (выгружает из iiko в 1с). При выгрузке акта реализации в 1с необходимо НЕ выгружать/удалить/скрыть часть документа(ту часть, в которой в этом документе в колонке "операция название" стоит "продажа").Т.е. в выгруженном акте были бы все строки и колонки таблицы только с операцией "списание" в колонке "операция название".
Я думаю изменить часть кода в процедуре ЗагрузитьДокументыИзФайлов():
Привожу часть кода:

Процедура ЗагрузитьДокументыИзФайлов()

соединение = СтрокаСоединенияИнформационнойБазы();
КаталогБазы = Прав(соединение,СтрДлина(СтрокаСоединенияИнформационнойБазы())-6);
КаталогБазы = Лев(КаталогБазы,СтрДлина(КаталогБазы)-2);

ЗагрузитьЕденицыИзмеренийИзДбф();

ОшибкаФайла = Ложь;

Если ПН тогда
ФС = Новый Файл(Каталог1с + "Приходная накладная.csv");
Если НЕ Фс.Существует() Тогда
Сообщить("Файл приходных накладных " + Каталог1с + "Приходная накладная.csv не найден!!!", СтатусСообщения.Важное);
ОшибкаФайла = Истина;
//Продолжить;
КонецЕсли;

Если ОшибкаФайла = Ложь тогда
Текст = Новый ЧтениеТекста(Каталог1с + "Приходная накладная.csv",КодировкаТекста.ANSI);
АдресПН = ПолучитьТЗ(Текст,НачИменаКолонок,УмныеИменаКолонок);
Иначе
АдресПН = неопределено
КонецЕсли;
КонецЕсли;

ОшибкаФайла = Ложь;
Если АР тогда
ФС = Новый Файл(Каталог1с + "Акт реализации.csv");
Если НЕ Фс.Существует() Тогда
Сообщить("Файл актов реализации " + Каталог1с + "Акт реализации.csv не найден!!!", СтатусСообщения.Важное);
ОшибкаФайла = Истина;
КонецЕсли;

Если ОшибкаФайла = Ложь тогда
Текст1 = Новый ЧтениеТекста(Каталог1с + "Акт реализации.csv",КодировкаТекста.ANSI);
АдресАР = ПолучитьТЗ(Текст1,НачИменаКолонок1,УмныеИменаКолонок1);
Тз1 = ПолучитьИзВременногоХранилища(АдресАР);

Если Тз1.Колонки.Найти("ПроданноеБлюдоКод") <> неопределено Тогда
ВерсияАйко = 2;
АдресВерсииАйко = ПоместитьВоВременноеХранилище(ВерсияАйко, УИДФормы);
КонецЕсли;
АдресАР = ПоместитьВоВременноеХранилище(Тз1, УИДФормы)
Иначе
АдресАР = неопределено;
КонецЕсли;
КонецЕсли;

где АР - акт реализации.

Если дальше прописать: что-то вроде Тз1.Колонки.Найти("ОперацияНазвание")<>"Продажа" тогда

....
КонецЕсли;


Или это надо сделать как-то по-другому?
Если нужно, скину весь этот файл внешней обработки.
0
Выбранные исполнители
Отклики
Чтобы добавить свое предложение, Вам необходимо авторизоваться либо зарегистрироваться.
    На главную страницу ≡ к списку заданий 1С