Информационный поток
Задания вакансии материалы разработки сообщения форума
vavilova.alena
Приватное сообщение

необходимо написать блок схему к коду

Задача добавлена через сайт партнера Форум 1С
2 | 0
18 июня 2015 в 10:12:17(1 год 24 недели 4 дня 7 часов назад)
1000
Текст задания
Процедура ОбработкаПроведения(Отказ, Режим)
//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ОстаткиЗаготовок Расход
Движения.ОстаткиМатериалов.Записывать = Истина;
Движения.СтоимостьМатериалов.Записывать = Истина;
Движения.Продажи.Записывать = Истина;

Для Каждого ТекСтрокаУслуги Из Услуги Цикл
Если ТекСтрокаУслуги.Услуга.ВидУслуги = Перечисления.ВидыУслуг.Материал Тогда
Движение = Движения.ОстаткиМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Материал = ТекСтрокаУслуги.Услуга;
Движение.Количество = ТекСтрокаУслуги.Количество;
// регистр СтоимостьМатериалов Расход
Движение = Движения.СтоимостьМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Материал = ТекСтрокаУслуги.Услуга;

КонецЕсли;
//регистрПродажи
Движение = Движения.Продажи.Добавить();
Движение.Период = Дата;
Движение.Услуга = ТекСтрокаУслуги.Услуга;
Движение.Заказчик = Заказчик;
Движение.Сотрудник = Сотрудник;
Движение.Количество = ТекСтрокаУслуги.Количество;
Движение.Выручка = ТекСтрокаУслуги.Сумма;

КонецЦикла;

Если ЭтотОбъект.ДатаГотовностиЗаказа = Дата(1,1,1) Тогда
ЭтотОбъект.ДатаГотовностиЗаказа = ТекущаяДата()+(3600*48)
КонецЕсли;

Если ЭтотОбъект.Задача = Задачи.Задачи.ПустаяСсылка() Тогда
НоваяЗадача = Задачи.Задачи.СоздатьЗадачу();

НоваяЗадача.Дата = ТекущаяДата();
НоваяЗадача.ДатаНапоминания = ЭтотОбъект.ДатаГотовностиЗаказа;
НоваяЗадача.Клиент = ЭтотОбъект.Заказчик;
НоваяЗадача.Заказ = ЭтотОбъект.Ссылка;
НоваяЗадача.Наименование = "Готов заказ клиента";
НоваяЗадача.Сообщение = "Необходимо позвонить клиенту - "+ НоваяЗадача.Клиент + " - " + НоваяЗадача.Клиент.ТелефонЗаказчика + " его заказ готов!";

НоваяЗадача.Записать();

Иначе

ТекЗадача = ЭтотОбъект.Задача.ПолучитьОбъект();

ТекЗадача.ДатаНапоминания = ЭтотОбъект.ДатаГотовностиЗаказа;

ТекЗадача.Записать();

КонецЕсли;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры
0
Отклики (9)
Чтобы добавить свое предложение, Вам необходимо авторизоваться либо зарегистрироваться.
    На главную страницу ≡ к списку заданий 1С