Информационный поток
Задания вакансии материалы разработки сообщения форума
tourist56
Приватное сообщение
Новый заказчик

Глюк с формированием массива

Задача добавлена через сайт партнера Форум 1С
18 января 2015 в 10:56:12(1 год 45 недель 6 дней 10 часов назад)
Текст задания
Платформа 8.3.5.1383. Делаю обработку загрузки данных из файла dbf.
Примерно такая процедура:
&НаКлиенте
Процедура СоздатьСФ(Команда)
Данные= Новый XBase;
Данные.ОткрытьФайл(Объект.ФайлДанных,,Истина);
Структура=Новый Структура();
НаборДанных = Новый Массив;
Запись = Новый Структура;
НаборДанных.Очистить();
Если Не Данные.Открыта() Тогда
Предупреждение("Не удалось открыть указанный файл!");
Иначе
КолЗаписей=Данные.КоличествоЗаписей();
Для НомЗап=1 по КолЗаписей Цикл
Данные.Перейти(НомЗап);
Запись.Вставить("ДатаДок",Данные.DataDok);
Запись.Вставить("НомерДок",Данные.NomDok);
Запись.Вставить("СФНомер",Данные.SchF);
Запись.Вставить("ДСФ",Данные.DataSchF);
Запись.Вставить("Основание",Неопределено);
НаборДанных.Вставить(НомЗап-1,Запись);
Сообщить("Номер док."+Запись.НомерДок+" Номер записи "+НаборДанных.Количество());
КонецЦикла;
Для каждого Запись из НаборДанных Цикл
Сообщить("Номер док."+Запись.НомерДок+" НомерСФ "+Запись.СФНомер);
КонецЦикла;

ДостатьОсн(НаборДанных);
СФ(НаборДанных);
Сообщить("Счета-Фактуры заполнены");
КонецЕсли;

КонецПроцедуры

Проблема в следующем. Когда по циклу выбираются данные из dbf, все нормально. Запись содержит нужную информацию.
По окончании цикла просматриваю массив. Все записи массива содержат последнюю Запись выборки. В чем может быть проблема?
Аналогичный код в другой процедуре работает нормально.
0
Отклики (1)
Чтобы добавить свое предложение, Вам необходимо авторизоваться либо зарегистрироваться.
    На главную страницу ≡ к списку заданий 1С