Информационный поток
Задания вакансии материалы разработки сообщения форума
Jer_ro i++
Приватное сообщение
Новый заказчик

Работа документа

18 декабря 2014 в 11:58:54(1 год 50 недель 2 дня 15 часов назад)
Текст задания
При записи документа со статусом "выполнено" проверять наличие ошибок (не стоит галка статус этапа) и предлагать по каждой строке создать задачу. Статус- реквезит документа.Статус этапа, флажок в табличной части.

Сначало хочу проверять стоит ли статус "выполнено", если да то проверка заполнения поля в табличной части и далее предлагать пользователю создать задачу. Подскажите пожалуйста, правильно ли выполняю или может быть где есть подобный пример?


&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

Объект.Статус = "Выполнен";
Для Каждого Строка Из Объект.ШаблонМониторинга Цикл
Если Объект.Статус = ПредопределенноеЗначение("Перечисление.СтатусМониторинга.Выполнено") Тогда

КонецЕсли;
КонецЦикла;

Если ЗначениеЗаполнено() Тогда
Сообщить("Не стоит флажок ""Статус этапа""");
Отказ = Истина;
КонецЕсли;

Если Вопрос("Создать новую задачу?",РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда
Отказ=Истина;

КонецЕсли;
КонецПроцедуры
0
Отклики (1)
Чтобы добавить свое предложение, Вам необходимо авторизоваться либо зарегистрироваться.
    На главную страницу ≡ к списку заданий 1С