Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к заданию: Включить возможность отладки 1С

    • #1
    • 10.08.2015 13:11
    0
    1С крутится на сервере в серверном варианте. К нему подключается компьютер по сети, программист заходит там в конфигуратор. Необходимо настроить возможность отладки при такой архитектуре. Сразу с...  Подробнее>>
    • #2
    • 10.08.2015 13:11
    0
    а в параметрах пользователя стоит возможность отладки текущего сеанса?
    • #3
    • 10.08.2015 13:21
    0
    Пусть проверит Подключенные предметы отладки. Есть там его сеанс или нет. Конфигуратор - Откладка - Подключение
    • #4
    • 10.08.2015 13:21
    0
    Работаете под толстым клиентом?
    • #5
    • 10.08.2015 13:23
    0
    Вообще я если честно не верю в то что описал автор. Должно все работать.
    • #6
    • 10.08.2015 13:49
    0
    Как подключаеться к серверу?
    • #7
    • 10.08.2015 15:14
    0
    К серверу подключение через конфигуратор через строку соединения

    Чигирь Сергей
    Подключенные предметы отладки. Есть там его сеанс или нет


    Есть

    Черноусов Филипп Сергеевич
    а в параметрах пользователя стоит возможность отладки текущего сеанса


    да
    • #8
    • 10.08.2015 21:02
    0
    Судя по описанной проблеме и комментариям, нужно смотреть файрвол (брандмауэр).
    • #9
    • 10.08.2015 22:30
    +1
    Судя по описанию проблемы следует поменять программиста 1С
    • #10
    • 11.08.2015 07:39
    0
    У Вас подключение по COM-Соединению к серверу (или веб-сервис, HTTP и прочая экзотика с выполнением кода на другом ПК?). Делаю аналогичную работу.
    • #11
    • 11.08.2015 07:46
    0
    Вот единственное концов не найти при COM-подключении если в модуле внешнего подключения в конфигурации на сервере (куда подключаемся из другой конфигурации) стоит функция выполнения произвольного кода, передаваемого как текст? Тут только факт регистрации ошибок можно есть или нет. Может, Вам нужно разбить логику решения и разбить на мелкие этапы при передаче и выполнении кода на сервере?
    //#Доработка(+) НН ###
    
    // Подставить во все экспортные функции модуля внешнего соединения (и прочих модулей с разрешенным внешним подключением!!!)
    Процедура ПроверкаБезопасности() // Защита от попытки выполнения вредоносного кода при внешнем подключении от имени другого пользователя. 
    	ТекПользователь = ПараметрыСеанса.ТекущийПользователь;
    	Если ТекПользователь.Пустая() Тогда
    		ВызватьИсключение("Внимание!!! Параметр сеанса ТекущийПользователь не инициализирован (попытка внешнего подключения к базе Весы)");
    	КонецЕсли;	
    	ПользовательИБ = Справочники.Пользователи.НайтиПоНаименованию(ТекПользователь.Наименование, Истина);
    	Если ПользовательИБ.Наименование = "КомОбмен" Тогда
    		Возврат; // Все ОК
    	Иначе
    		ВызватьИсключение("ВНИМАНИЕ!!! Попытка внешнего подключения к базе Весы (через модуль внешнего подключения)");
    	КонецЕсли;	
    КонецПроцедуры	
    
    Функция ИсполнитьВн(КодВыполнить, ВспомПараметр= "") Экспорт
    	ПроверкаБезопасности(); // Защита от попытки выполнения вредоносного кода при внешнем подключении от имени другого пользователя.
    	
    	Ответ = "0";//Если ничего не нужно будет возвращать, то при отсутствии ошибок в коде 
    	//вернется просто ОК
    	//Т.к. переданный код может быть с ошибками, то завернем его исполнение в попытку.
    	Попытка
    		Выполнить(КодВыполнить); // Выполнение кода как строки на другом компьютере по COM-Соединению (Модуль внешнего соединения базы Весы)
    	Исключение
    		//если все таки ошибка, то вернем ее текст 
    		Ответ = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() );
    	КонецПопытки;
    	
    	Возврат Ответ;
    	
    КонецФункции
    
    Функция ТестСвязи(ВхПараметр, ВыхПараметр) Экспорт
    	ПроверкаБезопасности(); // Защита от попытки выполнения вредоносного кода при внешнем подключении от имени другого пользователя.
    	ВыхПараметр = "Есть связь с базой весы по COM-Соединению!";
    	Возврат Истина;
    КонецФункции	
    
    Функция ПолучитьТаблицуКонтрагентовИДоговоров() Экспорт
    	ПроверкаБезопасности(); // Защита от попытки выполнения вредоносного кода при внешнем подключении от имени другого пользователя.
    	Запрос = Новый Запрос;
    	Запрос.Текст =
    	"ВЫБРАТЬ
    	|	ДоговорыКонтрагентов.Владелец,
    	|	ДоговорыКонтрагентов.Код КАК КодДоговора,
    	|	ДоговорыКонтрагентов.Груз,
    	|	ДоговорыКонтрагентов.Цена,
    	|	ДоговорыКонтрагентов.НДС,
    	|	ДоговорыКонтрагентов.НомерДоговора КАК НомерДоговора,
    	|	ДоговорыКонтрагентов.ДатаДоговора КАК ДатаДоговора
    	|ИЗ
    	|	Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
    	|
    	|УПОРЯДОЧИТЬ ПО
    	|	НомерДоговора,
    	|	ДатаДоговора";
    	
    	Возврат Запрос.Выполнить().Выгрузить();
    	
    КонецФункции	
    
    //.Доработка(-) ...
    • #12
    • 11.08.2015 21:10
    0
    Если действительно работаете с COM-соединением, то включение отладки для внешнего соединения дело сложное. Самое подробное по всем граблям для включения отладки при внешнем соединении http://infostart.ru/public/387577/?ref=711
    Тут и сисадминство и параметры запуска 1С...
    Проще упростить технологию
    • #13
    • 14.08.2015 09:12
    0
    Ситуация немного прояснилась - отключил брандмауэр, отладка заработала. Соответственно, требуется грамотная настройка брандмауэра для корректной работы 1С по Windows Server 2012
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться