Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Проблемы с кодом

    • #1
    • 01.07.2015 19:14
    0
    Есть код:

    Процедура ВидПоощренияПриИзменении(Элемент)

    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ ПЕРВЫЕ 1
    | ВидыПоощрений.Баллы КАК Баллы
    |ИЗ
    | Справочник.ВидыПоощрений КАК ВидыПоощрений
    |ГДЕ
    | ВидыПоощрений.Ссылка = &Ссылка";

    Запрос.УстановитьПараметр("Ссылка",ВидПоощрения);

    Результат = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = Результат.Выбрать();

    Если ВыборкаДетальныеЗаписи.Следующий() Тогда
    Баллы = ВыборкаДетальныеЗаписи.Баллы ;
    КонецЕсли;

    КонецПроцедуры

    Что в нем изменить, чтобы при выборе поля из справочника ВидыПоощрений автоматически заполнялось поле Баллы и того же справочника
    • #2
    • 21.07.2015 15:45
    0
    Можно так:
    Если ВыборкаДетальныеЗаписи.Следующий() Тогда
    ТекОбъкт = Ссылка.ПолучитьОбъект();
    ТекОбъкт.Баллы = ВыборкаДетальныеЗаписи.Баллы ;
    Попытка
    ТекОбъкт.Записать();
    Исключение
    Сообщить("Не удалость записать эл.справочника Виды поощрения"+Строка(Ссылка));
    КонецПопытки;
    КонецЕсли;
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться