Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к контенту: Аудит компьютеров и программного обеспечения

    • #1
    • 30.04.2012 11:45
    0
    • #2
    • 23.09.2014 13:13
    0
    данная разработка выдала ошибку в самом начале при подключении к серверу.
    • #3
    • 23.09.2014 13:14
    0
    ФормаОжидание = ПолучитьФорму("Ожидание",ЭтаФорма,"Поиск новых компютеров в домене...");
    ФормаОжидание.Открыть();
    Попытка
    Соединение=Новый COMОбъект("ADODB.Connection");
    РекордСет=Новый COMОбъект("ADODB.Recordset");
    Соединение.ConnectionString = "Provider=ADsDSOObject;Encrypt Password=False;Mode=Read;Bind Flags=0;ADSI Flag=1";
    Соединение.Open();
    ТекстЗапроса = "SELECT * FROM 'LDAP://DC="+Домен+",DC=ru' WHERE objectCategory='Computer' ORDER BY cn";
    РекордСет.Open(ТекстЗапроса,Соединение,2,3);
    Состояние("Поиск новых компов в домене...");
    //сч = 0;
    СпДоменныхСтрок = Новый СписокЗначений();
    Пока РекордСет.Eof()=0 Цикл
    //Сч = Сч + 1;

    ДоменнаяСтрока = РекордСет.Fields("aDSpath").Value;
    ДоменнаяСтрока = СтрЗаменить(ДоменнаяСтрока,"LDAP://CN=","");
    ДоменнаяСтрока = СтрПолучитьСтроку(СтрЗаменить(ДоменнаяСтрока,",",Символы.ПС),1);
    СпДоменныхСтрок.Добавить(ДоменнаяСтрока);
    Если Справочники.Компьютеры.НайтиПоНаименованию(ДоменнаяСтрока,Истина).Пустая() Тогда
    СтрНового = ТабНовых.Добавить();
    СтрНового.Компьютер = ДоменнаяСтрока;
    КонецЕсли;

    РекордСет.MoveNext();
    КонецЦикла;

    Исключение
    ФормаОжидание.Закрыть();
    КонецПопытки;
    ФормаОжидание.Закрыть();
    Соединение = Неопределено;
    РекордСет = Неопределено;
    КонецПроцедуры
    • #4
    • 23.09.2014 13:44
    0
    Очевидно, что не удалось подключиться к вашему домену через ADODB.Connection. Причин тому может быть масса: у вас нет домена, неверная строка соединения, недостаточно прав и прочее. Нужна строка соединения, которая подойдет для вашей сети.
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться