Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к заданию: Запись чисел в 1С

    • #1
    • 03.04.2015 12:09
    0
    Помогите пожалуйста. Надо записать заданное число: 1,2,3,4,5 в обратном порядке и вывести его на экран.  Подробнее>>
    • #2
    • 03.04.2015 12:09
    0
    Число или цифры через запятую?
    Контрольный пример напишите!
    • #3
    • 03.04.2015 12:11
    0
    И самое интересное - куда записать, перед тем, как вывести его на экран )))
    • #4
    • 03.04.2015 12:13
    0
    Программисту 1С Вирта и Кнута читать не обязательно...
    • #5
    • 03.04.2015 12:31
    0
    задача конечно - еще та - переведите ее хотя бы в песочницу. или вы надеетесь что кто-то бесплатно сделает? тогда это немного на другой сайт
    • #6
    • 03.04.2015 13:11
    0
    Числа от 1 до 5 записать в обратном порядке.
    Моё задание от преподавателя звучит так: "Записать заданное число в обратном порядке".
    А куда его записывать он не сказал.
    • #7
    • 03.04.2015 13:32
    0
    Кидай 200 р на тел напишу код.
    • #8
    • 03.04.2015 14:35
    0
    Тут уже подсказали 90% :)
    Но злой препод спросит: "А что делает вот эта процедура и как ее самому написать? СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(Строка1,",");"
    • #9
    • 03.04.2015 14:36
    0
    Причем на спор - студент даже если будет конфигурация не найдет :)
    • #10
    • 03.04.2015 14:44
    • Отредактировано: 03.04.2015 15:00:08
    +1
    Azrael375
    Числа от 1 до 5 записать в обратном порядке.
    Моё задание от преподавателя звучит так: "Записать заданное число в обратном порядке".
    А куда его записывать он не сказал.


    Я сделал!!!

    СП = Новый СообщениеПользователю;
    СП.Текст = "54321";
    СП.Сообщить();
    


    :-)
    • #11
    • 03.04.2015 17:30
    0
    Процедура Команда1(Команда)
    РО = Объект.Реквизит1;
    Длина_РО = СтрДлина(РО);
    СтрДляВывода = "";
    Для к = 1 По Длина_РО Цикл
    Символ_РО = Сред(РО, Длина_РО - к + 1, 1);
    Если Найти("0123456789", Символ_РО) Тогда
    СтрДляВывода = СтрДляВывода + Символ_РО;
    КонецЕсли;
    КонецЦикла;
    Сообщить(СтрДляВывода);
    КонецПроцедуры

    Реквизи1 = это реквизит на форме с типом строка.
    • #12
    • 03.04.2015 17:49
    0
    А потом студент спросит. Все равно не запускается или не так работает.
    • #13
    • 04.04.2015 19:00
    0
    Смирнов Павел Валерьевич
    РО = Объект.Реквизит1;


    Тру одинэсники делают такъ:

    Перем Реквизит1;
    Если ВвестиЧисло(Реквизит1, "Введите числа через запятую") Тогда
    [...]
    КонецЕсли;
    • #14
    • 04.04.2015 19:32
    • Отредактировано: 04.04.2015 19:54:34
    0
    Прикольно! Чем простее задача, тем больше обсуждений. Ай-кью у обсуждающих высокий-базара нет, но почему-то никто не поднял тему- а не прикалываются ли с вас?
    • #15
    • 04.04.2015 20:08
    0
    Владимир Николаевич
    Прикольно! Чем простее задача, тем больше обсуждений. Ай-кью у обсуждающих высокий-базара нет, но почему-то никто не поднял тему- а не прикалываются ли с вас?

    Ну я-то точно прикалываюсь, так что тема - позитивная.
    И кстати, чем проще задача, тем интереснее генерить идеи по её решению.
    Иначе использование одних и тех же приемов в разработке давно превратило бы работу в рутину =)
    • #16
    • 06.04.2015 01:13
    • Отредактировано: 06.04.2015 01:26:49
    0
    uses crt;
    var
    number, conv, i : integer;
    begin
    write('Введите число : '); readln(number);

    conv := 0;

    while (number >0) do
    begin
    i := number mod 10 ;
    conv := conv*10 + i ;
    number := number div 10;
    end;

    writeln('Обратная запись числа: ', conv);
    readln;
    end.

    вот на паскале
    • #17
    • 06.04.2015 08:10
    0
    Может так сотрудников гениальных отбирают. Как в одном анекдоте.
    Приезжает в дурдом комиссия. Спрашивают главврача: как Вы определяете что больной вылечился? Тот им: А мы делаем так. Ставим тазик открываем оба крана, даем в руки ковшик и предлагаем вычерпать воду. Комиссия: и что? Главврач: Ну если человек нормальный, он первым делом краны закрутит :)
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться