Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Вывести картинку

    • #1
    • 17.11.2014 13:50
    0
    1С ERP 2.0 , в справочнике добавил дополнительные сведения — файл (картинка).
    Ни как не могу его вывести на печатную форму...
    То несоответствие типа, то файл не найден, а если использую «Получить()» - не обнаружен метод.

    Рис.Картинка = Новый Картинка(ВыборкаЗапрос.Значение.Ссылка.Получить());
    • #2
    • 17.11.2014 13:54
    0
    с картинками в 1С всё неоднозначно сделано.
    Картинка может быть - и картинкой как объект, и картинка как предмет (ну не знаю как сказать правильно).
    надо в отладчике смотреть (проверять значения) и делать исходя из увиденного.
    • #3
    • 18.11.2014 10:40
    0
    Переделал:
    &НаСервере
    Процедура ПолучитьКартинку(Пппп,ПодписьСотрудника)
    	ПС =  ПоместитьВоВременноеХранилище(Пппп.Значение,Новый УникальныйИдентификатор);
    КонецПроцедуры
    



    Рис.Картинка =  Новый Картинка(ПС);


    Теперь:"Каталог не обнаружен e1cib\tempstorage\....."

    есть идеи?
    • #4
    • 19.11.2014 17:15
    • Отредактировано: 19.11.2014 17:17:34
    +1
    Решено собственными силами
    Процедура ПолучитьКартинку(Пппп,ПСотрудника)
    	Запрос = Новый Запрос;
    	Запрос.Текст = 
    	"ВЫБРАТЬ
    	|	ПрисоединенныеФайлы.ПрисоединенныйФайл,
    	|	ПрисоединенныеФайлы.ХранимыйФайл,
    	|	ПрисоединенныеФайлы.ПрисоединенныйФайл.Наименование
    	|ИЗ
    	|	РегистрСведений.ПрисоединенныеФайлы КАК ПрисоединенныеФайлы
    	|ГДЕ
    	|	ПрисоединенныеФайлы.ПрисоединенныйФайл.Наименование = &П";
    		
    		Запрос.УстановитьПараметр("П", Пппп.Значение.Наименование);
    		Выборка = Запрос.Выполнить().Выбрать();
    		
    		Если Выборка.Следующий() Тогда
    			ПСотрудника = Выборка.ХранимыйФайл.Получить();
    		Иначе
    			Сообщить("Файл <" + Строка(Пппп.Значение.Наименование) + "> не найден!",);
    		КонецЕсли;
    
    КонецПроцедуры
    


    ПолучитьКартинку(Пппп,ПСотрудника);
    	Рис.Картинка =  Новый Картинка(ПСотрудника);
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться