Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Программная установка параметров СКД

    • #1
    • 23.10.2014 09:02
    • Отредактировано: 23.10.2014 09:12:24
    0
    Здравствуйте, не получается с отбором. Поставил точку останова, перебрал все свойства не чего не нашел. Может как то по другому можно реализовать?



    &НаКлиенте
    Процедура ТолькоРазработкаПриИзменении(Элемент)		
    	Если ЗначениеЗаполнено(ЭтаФорма.ТолькоРазработка) Тогда
    		КомпоновщикНастроек = Отчет.КомпоновщикНастроек.Настройки;
    		ПараметрСКД = КомпоновщикНастроек.Отбор.Элементы[0].Использование=Истина;
    		ПараметрСКД.Значение = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Разработка");
    		ПараметрСКДФикс = КомпоновщикНастроек.Отбор.Элементы[0].Использование = Истина;
    		ПараметрСКДФикс.Использование = Истина;
    		ПараметрСКДФикс.Значение = ПараметрСКД.Значение;
    		ПараметрСКД = КомпоновщикНастроек.Отбор.Элементы[0].Использование;
    		ПараметрСКД.Использование=Истина;
    		ПараметрСКД.Значение = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Разработка");
    		ПараметрСКДФикс = КомпоновщикНастроек.Отбор.Элементы[0].Использование;
    		ПараметрСКДФикс.Использование = Истина;
    		ПараметрСКДФикс.Значение = ПараметрСКД.Значение;
    	КонецЕсли;
    КонецПроцедуры
    • #2
    • 23.10.2014 09:17
    0
    Александр Сергеевич
    Может как то по другому можно реализовать?
    он не находит ничего (сейчас) - если в отборе нет элементов.

    смотрите в синтакс-помощнике - метод Добавить(<Описание>, <Имя>, <Представление>) для универсального объекта Отбор:
    Отбор = ОтчетОстатки.ПостроительОтчета.Отбор;
    Если Отбор.Найти("Номенклатура") = Неопределено Тогда
        Отбор.Добавить("Номенклатура");
    КонецЕсли;
    Отбор["Номенклатура"].Использование = Истина;
    Отбор["Номенклатура"].Значение      = Номенклатура;
    Отбор["Номенклатура"].ВидСравнения  = 
            ?(Номенклатура.ЭтоГруппа, 
                ВидСравнения.ВСпискеПоИерархии, 
                ВидСравнения.Равно);

    См. также:
    Отбор, метод УстановитьДоступныеПоля
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться