Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Работа документа при записи

    • #1
    • 29.09.2014 14:41
    0
    Подскажите пожалуйста? При записи документа с реквизитом статус проверка заполнения табличного поля статус этапа (вид поле флажка), так же по каждой строке создавать задачу, при перезаписи не предлагать.
    Делаю только проверку заполнения флажка в табличном поле, не знаю как привязать к реквизиту статус. Скажите что доделать нужно?
    Извиняюсь за глупый код....
    &НаКлиенте
    Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    Если ЗначениеЗаполнено("СтатусЭтапа") Тогда
    Сообщить("Не стоит флажок ""Статус этапа""");
    Отказ = Истина;
    КонецЕсли;

    Если Вопрос("Создать новую задачу?",РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда
    Отказ=Истина;

    КонецЕсли;
    КонецПроцедуры
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться