Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

ххееееллллпПП

    • #1
    • 03.09.2014 15:58
    0
    Друзья здравствуйте!
    помогите пожалуйста с обработкой.

    надо что бы с начало выводился контрагент и вся инфа, а с низу все что есть грузополучатели, и по наименованию что бы все было



    //*******************************************
    Процедура Сформировать()

    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Контакты = Справочник.КонтактыКлиентов.ТекущийЭлемент;


    |Группировка Контакты ;
    //|Группировка Грузополучатель;
    |"//}}ЗАПРОС
    ;


    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Отчет_По_Продажам");
    Таб.ВывестиСекцию("Заголовок");


    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;


    Пока Запрос.Группировка(1) = 1 Цикл

    Если Запрос.Контакты.Владелец.Родитель.Наименование <> "ОПТ" Тогда
    Продолжить;
    КонецЕсли;

    Таб.ВывестиСекцию("Накладная");

    Таб.ВывестиСекцию("Груз");


    КонецЦикла;
    //КонецЦикла;
    Таб.Показать("Отчет_По_Продажам", "");
    КонецПроцедуры
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться