Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к заданию: Торговля + Склад 8 ,77 Сделать возможность на основание документа "приходная...

    • #1
    • 18.03.2014 21:02
    0
    Торговля + Склад 8 , на платформе 77 Сделать возможность на основание документа "приходная накладная" вода документа "Передача в ТЗ". Конфигурация http://yadi.sk/d/n-b7j35GKkkth  Подробнее>>
    • #2
    • 18.03.2014 21:08
    • Отредактировано: 18.03.2014 21:09:51
    0
    Только что проверил: у вас итак, реализована "Передача в ТЗ" на основании "Приходной накладной"
    • #3
    • 18.03.2014 21:50
    0
    И в коде процедуры ввода на основании есть заполнение:

    Процедура ВводНаОсновании(ДокОснование)
    	Если 	(ДокОснование.Вид()="Счет") ИЛИ
     			(ДокОснование.Вид()="РасходнаяНакладная") ИЛИ
     			(ДокОснование.Вид()="ПриходнаяНакладная") ИЛИ
     			(ДокОснование.Вид()="РасходнаяРозничная") ИЛИ
     			(ДокОснование.Вид()="Чек") ИЛИ
     			(ДокОснование.Вид()="РасходнаяРеализатора") ИЛИ
     			(ДокОснование.Вид()="ПриходнаяРеализатора")  Тогда
    		ЗаполнитьШапкуНаОсн(Контекст,ДокОснование);
    		Если (ДокОснование.Вид()="РасходнаяНакладная") Тогда
    			ПризнакНакладной=Перечисление.ПризнПрихНакл.ВозвратОтПокупателя;
    			ДокументОснование=ДокОснование;
    		Иначе
    			ПризнакНакладной=Перечисление.ПризнПрихНакл.Закупка;
    		КонецЕсли;
    		ДатаДок=РабочаяДата();
    		Если (ДокОснование.Вид()="Счет") Тогда
    			Склад=Константа.ОсновнойСклад;
    		Иначе
    			Склад=ДокОснование.Склад;
    		КонецЕсли;
    		Валюта=ДокОснование.Валюта;
    		Дата_Курса=ДокОснование.Дата_Курса;
    	    Курс=ДокОснование.Курс;
    		Валюта_Прежн=Валюта;
    		Курс_Прежн=Курс;
    		Клиент=ДокОснование.Клиент;
    	//	ВыборКлиента();
    		ДокОснование.ВыбратьСтроки();
    		Пока ДокОснование.ПолучитьСтроку()=1 Цикл
    			НоваяСтрока();
    			Товар=ДокОснование.Товар;
    			Единица=ДокОснование.Единица;
    			Коэффициент=ДокОснование.Коэффициент;
    			Количество=ДокОснование.Количество;
    			УстанЦеныПередачи(Контекст);
    		КонецЦикла;
    	Иначе
    		Предупреждение("Эту накладную нельзя вводить на основании выбранного вида документа!");
    		СтатусВозврата(0);
    	КонецЕсли;
    КонецПроцедуры
    
    
    • #4
    • 19.03.2014 08:37
    0
    Действительно , вам спасибо большое за подсказку :-). Извиняюсь пере всем на потраченное время. Задача снимается.
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться