Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

настройка почты Exchange

    • #1
    • 27.12.2011 11:45
    0
    есть рабочая почта, учетная запись которой настроена в Exchange сервере.
    вопрос: как при этом настроивать SMTP и POP3 сервера в 1С:КА 8.2?
    если писать POP3 через айпишник, то непонятно что писать в поле "пользователь", на все попытки выдает ошибку:

    Ошибка при вызове метода контекста (Подключиться): Почтовый ящик пользователя "..." на сервере "..." не найден. Ответ сервера: "5.3.3 Unrecognized command"

    если кто настраивал локальную почту в 1С, напишите хоть примерно как строится в таком случае поле "пользователь"???
    • #2
    • 27.12.2011 12:37
    0
    Не знаю насчет КА, но в УПП у нас так (заменил реальные адреса, примером)
    • #3
    • 27.12.2011 12:38
    0
    Еще в конфе есть процедура самописная. Работает вроде.

    Процедура ОтправитьСпам(Текст,массивАдресатов,Тема ,Отправитель ,Пароль,массивАдресатовКопий = Неопределено) Экспорт
    		
    		ИПП = Новый ИнтернетПочтовыйПрофиль; 
    		ИПП.АдресСервераSMTP = "exchange.examle.ru"; 
    		ИПП.ВремяОжидания = 60; 
    		ИПП.Пароль = Пароль; 
    		ИПП.Пользователь = Отправитель; 
    		ИПП.ПортSMTP = 25; 
    
    		Сообщение = Новый ИнтернетПочтовоеСообщение; 
    		Для  Каждого Адресат Из массивАдресатов  Цикл
    			Сообщение.Получатели.Добавить(Адресат); 	
    		КонецЦикла;	
    		
    		Если массивАдресатовКопий <> Неопределено Тогда
    			Для  Каждого Адресат Из массивАдресатовКопий  Цикл
    				Сообщение.Копии.Добавить(Адресат); 	
    			КонецЦикла;	
    		КонецЕсли;
    		
    		Сообщение.Отправитель.Адрес = Отправитель; 
    		Сообщение.Тема = Тема; 
    		Сообщение.Тексты.Добавить(Текст);
    		// Подключиться и отправить. 
    		Почта = Новый ИнтернетПочта; 
    		Почта.Подключиться(ИПП); 
    		Почта.Послать(Сообщение); 
    		Почта.Отключиться(); 
    	
    КонецПроцедуры // ОтправитьСпам  
    
    • #4
    • 27.12.2011 13:17
    0
    проблема в том, что СМТП и ПОП3 сервера заданы в форме IP, а не в прямом названии этих серверов.
    насколько я помню в случае когда мы пробовали выход на почту через вэб-интерфейс, то там из-за того что сервер записан в виде IP, приходилось добавлять какой-то префикс перед пользователем, но вот какой - в упор не помню, а админа нет...
    вот я и подумал, что скорее всего этот префикс должен быть более-менее стандартным в плане структуры своей и может кто настраивал почту так...
    • #5
    • 27.12.2011 14:29
    0
    По-моему вообще без разницы как имя задано, если dns не глючит. А имя пользователя попробуйте написать такое же, как и для входа в домен. ИмяПользователя@имявашегодомена.ru
    • #6
    • 27.12.2011 14:39
    0
    пробовал, не катит...
    днс - хз, хотя на сколько я помню днс нужен как раз чтобы стандартное имя сервера перевести в IP вид, а не обратно.
    внешняя почта настроилась идеально (яндекс)
    может проблема в прокси?
    он никак не может повлиять на такой вид записи имени сервера и возможность подключиться к нему?
    • #7
    • 27.12.2011 15:54
    0
    Прокси может повлиять на всё. Попробуйте для из командной строки ping по адресу, по имени, потом подключиться к портам 25,110, или какие на вашем сервере.
    • #8
    • 27.12.2011 16:01
    0
    пинг по адресу и имени чего? сервера?
    так тут всё ок, на сервер он попадает нормально, но там не находит пользователя ящика почтового... вот в чем загвоздка...
    • #9
    • 15.10.2013 13:13
    0
    решение проблемы в проверке подлинности. Смотреть тут:

    http://www.alexxhost.ru/2010/06/exchange-2010-pop3.html
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться