Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к заданию: Перенумеровать штрихкоды(заменить символ) и изменить обработку подбора по штрихкоду УТ 11

    • #1
    • 23.12.2013 22:05
    0
    В УТ 11 вели учет. Вдруг возникла необходимость загружать данные от поставщиков. Вместе с штрихкодами. И теперь при загрузке вместо того, чтобы создать новую номенклатуру - программа выбирает уже ...  Подробнее>>
    • #2
    • 24.12.2013 08:40
    0
    вопрос на 500 рублей и 30 мин времени
    итак, по порядку:
    1)
    Функция ЗаменитьШтрихКод(смШтрихКод)
          Возврат Лев(смТовар.ШтрихКод, 2) + "83" + Прав(смТовар.ШтрихКод, 8);
    КонецФункции
    
    //----------------
    ...
    НачатьТранзакцию();
    ВыборкаТоваров = Справочники.Номенклатура.Выбрать();
    Пока ВыборкаТоваров.Следующий() Цикл
    	смТовар = ВыборкаТоваров.ПолучитьОбъект();
           Если Число(смТовар.ШтрихКод) < ОпрЗнач Тогда
               //Например
               смТовар.ШтрихКод = ЗаменитьШтрихКод(смТовар.ШтрихКод);
               смТовар.Записать();
           КонецЕсли;
    КонецЦикла;
    ЗафиксироватьТранзакцию();
    ...
    


    2) что-то типа так
    Если ТоварПоШтрихКоду(считШтрихКод).Пустая() Тогда
         Если ТоварПоШтрихКоду(ЗаменитьШтрихКод(считШтрихКод)).Пустая() Тогда
          ...
         КонецЕсли;
    КонецЕсли;
    
    • #3
    • 24.12.2013 08:45
    0
    Umix
    вопрос на 500 рублей и 30 мин времени


    сразу видно - знающий человек...
    это УТ11, и в ней как и в большинстве типовых - штрихкоды пишутся в регистр сведений...
    • #4
    • 24.12.2013 13:04
    0
    Ну вот (( начался атракцион новогодней благотворительности, что не в пользу сайта
    • #5
    • 24.12.2013 13:19
    0
    Да какая тут благотворительность?
    Все как обычно. Человек и близко не видевший УТ11 грозится за 10 мин. всё порешать :)
    Через пару недель заказчик или побежит к франзайзи исправлять, либо начнет искать адекватные предложения.
    • #6
    • 24.12.2013 13:27
    0
    Вадим
    Да какая тут благотворительность?
    Все как обычно. Человек и близко не видевший УТ11 грозится за 10 мин. всё порешать :)
    Через пару недель заказчик или побежит к франзайзи исправлять, либо начнет искать адекватные предложения.


    Нет, Вадим... скорее всего будет не так.
    Через пару недель он глубоко укоренится в мысли что это работы на 5мин и 300рублей, просто нужно найти правильного человека....
    • #7
    • 24.12.2013 13:32
    0
    Антон Д.
    скорее всего будет не так


    точно :)
    • #8
    • 24.12.2013 13:33
    • Отредактировано: 24.12.2013 13:34:54
    0
    Вадим
    Через пару недель заказчик или побежит к франзайзи исправлять

    Заказчик и так франчайзи :)) Просто ему некогда мелочёвкой заниматься :)
    • #9
    • 24.12.2013 13:42
    0
    точнее менее чем 30-ю % от мелочёвки ))) я думаю если брать цену клиента и выделить долю специалиста франчайзи, и из доли специалита выделить бюджет на фрилансера. То в обратном направлении развернув это расчет 500 рублей легко превращаються в 1 час франчайзи по цене 2000 руб, плюс работы в базе клиента ещё 1 час (кто как накрутит). В итоге работу за 4000 рублей, фрилансер готов сделать за 500 рублей, а фрилансер с новогодним настроением бесплатно )))
    • #10
    • 26.12.2013 14:44
    0
    Интересно так комментарии читать)))
    Такими сайтами поэтому и пользуюсь, потому что цена/качество тут на хорошем уровне.
    Формула простая. Беру всех, кто отозвался, и из тех, у кого рейтинг вменяемый беру самого дешевого.
    Рынок, конкуренция, все дела....

    А с теми, кто делает бесплатно и "умеет все", стараюсь не связываться. Себе дороже выходит.

    У меня, кстати, все спецы внештатные. Правда и проекты небольшие.
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться