Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к заданию: Доработать механизм наценки 1с 7.7

    • #1
    • 17.12.2013 18:19
    0
    Добрый день. 1с 7.7 Похоже на самописную конфигурацию. Нужно доработать механизм наценки. База простейшая. Подключение через TeamViewer в любое время. Мне просто в лом вспоминать семерку ради одно...  Подробнее>>
    • #2
    • 17.12.2013 18:19
    0
    ИМХО, проще добавить у группы товара реквизит, чем отдельный справочник городить
    • #3
    • 17.12.2013 18:30
    0
    эт точно...
    • #4
    • 17.12.2013 19:20
    0
    Правильнее, действительно, добавить для группы реквизит "Наценка" и от него плясать.

    Иначе можно получить неопределённость с несколькими разными наценками для одной группы спровчника.
    • #5
    • 18.12.2013 08:35
    • Отредактировано: 18.12.2013 08:35:45
    0
    Попробуйте что-то типа вот этого

    //======================================================================
    Функция ПолучитьНаценку(смТовар)
    	смРодитель = смТовар.Родитель;
    	Пока ПустоеЗначение(смРодитель.ГрНаценка) = 1 Цикл
    		Если ПустоеЗначение(смРодитель) = 1 Тогда
    			Сообщить(СокрЛП(смТовар) +  " нет наценки ");
    			Возврат 0;
    		КонецЕсли;
    		смРодитель = смРодитель.Родитель;
    	КонецЦикла;
    	
    	Возврат смРодитель.ГрНаценка;		
    КонецФункции // ПолучитьНаценку
    
    //потом получаете цену
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    	Если Товар.Выбран() = 0 Тогда
    		Сообщить(" не выбран товар ");
    		Прервать;			
    	КонецЕсли;
    		
    	ЦенаРозн = Цена * (1 + ПолучитьНаценку(Товар)/100);
           //... и пишите ее туда куда вам надо
    КонецЦикла;
    
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться