Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к заданию: Основное изображение номенклатуры

    • #1
    • 24.03.2019 12:37
    0
    Кто поможет, ни как не выведу на печать: Запрос = Новый Запрос; Запрос.Текст = "ВЫБРАТЬ | Номенклатура.ОсновноеИзображение, | Номенклатура.ОсновноеИзображение.Хранилище,...  Подробнее>>
    • #2
    • 24.03.2019 12:38
    0
    Если Выборка.Следующий() Тогда

    ДвоичныеДанные = Выборка.ОсновноеИзображение.Получить();

    Если ДвоичныеДанные <> Неопределено Тогда

    мКартинка = Новый Картинка(ДвоичныеДанные,Истина);

    КонецЕсли;
    КонецЕсли;
    • #3
    • 24.03.2019 13:03
    0
    Да там скорее всего тип Хранилище значения. А в хранилище не факт что только двоичные данные могут быть
    • #4
    • 24.03.2019 13:16
    0
    а если не выводится напечать ? И ?
    • #5
    • 24.03.2019 16:54
    0
    А у номенклатуры реквизит ОсновноеИзображение имеет тип ДвоичныеДанные или ХранилищеЗначения?
    Если ХранилищеЗначения, то еще и Получить(...) двоичные данные из этого хранилища не мешало бы:

    Если Выборка.Следующий() Тогда
    ДвоичныеДанные = Выборка.ОсновноеИзображение.Получить();
    Если ТипЗнч(ДвоичныеДанные) = Тип("ДвоичныеДанные") Тогда
    мКартинка = Новый Картинка(ДвоичныеДанные,Истина);
    КонецЕсли;
    КонецЕсли;
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться