Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Подскажите что нетак! выходит такая ошибка

    • #1
    • 27.02.2013 13:38
    • Отредактировано: 27.02.2013 13:40:22
    0
    {Форма.Форма.Форма(10)}: Ошибка при вызове метода контекста (Записать)

    ДокументОбъект.Записать();

    по причине:

    Значение поля "Дата" не может быть пустой датой
    • #2
    • 27.02.2013 13:39
    • Отредактировано: 27.02.2013 13:40:08
    0
    ВОТ КОД
    Процедура КнопкаВыполнитьНажатие(Кнопка)

    ВыборкаПланПроизводства = Документы.ПланПроизводства.Выбрать(НачалоПериода, КонецПериода);


    Пока ВыборкаПланПроизводства.Следующий() Цикл

    ДокументОбъект = Документы.Заказнапроизводство.СоздатьДокумент();
    ДокументОбъект.Заполнить(ВыборкаПланПроизводства.Ссылка);
    ДокументОбъект.Записать();

    КонецЦикла;


    КонецПроцедуры
    • #3
    • 27.02.2013 14:22
    • Отредактировано: 27.02.2013 14:23:54
    0
    ДокументОбъект.Дата = КакаяТоДата;

    Предполагаю, что в процедуре обработки заполнения не отрабатывается автоматическое заполнение даты...
    • #4
    • 27.02.2013 14:38
    0
    в какую часть кода вставить вашу строку процедуры
    • #5
    • 27.02.2013 14:55
    0
    помогите пожалуйста! я вставил он выводит синтаксическую ошибку
    • #6
    • 27.02.2013 15:23
    0
    запустил обработку! пару секунд! подумала и никакого результата не произошло!
    • #7
    • 27.02.2013 16:37
    0
    запустил обработку! пару секунд! подумала и никакого результата не произошло! Что не так! тупо создает новый документ заказ на производство! а отбор документов план производства не происходит
    • #8
    • 28.02.2013 08:34
    0
    что не верного в этом коде:
    Запрос = Новый Запрос("Выбрать Источник.Номенклатура,Источник.Количество,Источник.Номенклатура.ЕдиницаИзмерения КАК ЕдиницаИзмерения,Источник.Спецификация,Источник.Ссылка.Дата КАК ДатаДокумента,Источник.Ссылка.Номер КАК НомерДокумента
    |ИЗ Документ.ПланПроизводства.КакТамВашаТабличнаяЧастьНазываетсяНеЗнаю КАК Источник
    |Где Источник.ссылка.Проведен, Источник.Дата между &НачалоПериода и &КонецПериода")
    Запрос.УстановитьПараметр("НачалоПериода", НачалоПериода);
    Запрос.УстановитьПараметр("КонецПериода", КонецПериода);
    Результат = Запрос.Выполнить()
    Если НЕ Результат.Пустой() Тогда
    Выборка = Результат.Выбрать();
    ЗаказНаПроизводство = Документы.Заказнапроизводство.СоздатьДокумент();
    Пока Выборка.Следующий() Цикл
    //тут получаем данные запроса и заполняем документ ЗаказНаПроизводство, только не методом Заполнить(), а каждый реквизит отдельно.
    КонецЦикла;
    КонецЕсли;
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться