Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Найти ошибку. помощи прошу

    • #1
    • 21.11.2017 13:11
    +1
    Ковырял Обработку ОбменССайтом с целью добавления туда типов значений "Булево"
    смотрел здесь (http://www.mikuslas.ru/node/86) и вписывал.
    уперся в то, что нужно доделать и не могу понять где именно. При проверке просит прописать "КонецЕсли"

    ({ОбщийМодуль.ОбменССайтом.Модуль(2480,2)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
    <<?>>КонецЦикла; (Проверка: Сервер)
    )


    сам КОД ниже

    ТипXML = "Строка";

    Если Типы.Количество() <> 1 Тогда

    // По стандарту CML можно выгрузить только один тип значений.
    // Выгружаем тип "Строка", как универсальный тип.

    СвойствоXDTO.ТипЗначений = ТипXML;

    Иначе

    Тип = Типы[0];

    Если Тип = Тип("Число") Тогда
    ТипXML = "Число";
    ИначеЕсли Тип = Тип("Дата") Тогда
    ТипXML = "Время";
    ИначеЕсли Тип = Тип("Булево") Тогда
    ТипXML = "Справочник";
    ИначеЕсли ТипЗначенияСправочник(Тип) Тогда
    ТипXML = "Справочник";
    КонецЕсли;

    СвойствоXDTO.ТипЗначений = ТипXML;

    Если ТипXML = "Справочник" Тогда

    ВариантыЗначенийСвойстваТип = ТипСвойство.Свойства.Получить("ВариантыЗначений").Тип;
    СправочникТип = ВариантыЗначенийСвойстваТип.Свойства.Получить("Справочник").Тип;

    ВариантыЗначенийXDTO = ФабрикаXDTO.Создать(ВариантыЗначенийСвойстваТип);

    Если Тип = Тип ("Булево") Тогда
    ОбъектXML.ЗаписатьНачалоЭлемента ("Справочник");
    ЗаписатьТекстовыйУзел (ОбъектXML, ОписаниеОшибокXML, "ИДЗначения", "YES");
    ЗаписатьТекстовыйУзел (ОбъектXML, ОписаниеОшибокXML, "Значение", "Да");
    ОбъектXML.ЗаписатьКонецЭлемента();
    Иначе
    ВариантыЗначений = ВариантыЗначенийСвойстваПоТипу(ВыборкаСвойствНоменклатуры, Тип);
    Для Каждого ВариантЗначения Из ВариантыЗначений Цикл
    Значение = Лев(ВариантЗначения, 1000);
    Если ПустаяСтрока(Значение) Тогда
    Продолжить;

    КонецЕсли;

    СправочникXDTO = ФабрикаXDTO.Создать(СправочникТип);

    СправочникXDTO.ИдЗначения = Строка(ВариантЗначения.УникальныйИдентификатор());
    СправочникXDTO.Значение = Значение;

    ВариантыЗначенийXDTO.Справочник.Добавить(СправочникXDTO);
    КонецЦикла;

    СвойствоXDTO.ВариантыЗначений = ВариантыЗначенийXDTO;
    КонецЕсли;

    КонецЕсли;

    СвойстваXDTO.Свойство.Добавить(СвойствоXDTO);

    КонецЦикла; //где-то здесь просит закрыть//

    Если СвойстваXDTO.Свойство.Количество() > 0 Тогда
    КлассификаторXDTO.Свойства = СвойстваXDTO;
    КонецЕсли;

    КонецПроцедуры
    • #2
    • 22.11.2017 14:06
    0
    КонецЦикла; //где-то здесь просит закрыть//

    - ТАКОЕ ОЩУЩЕНИЕ, ЧТО ВМЕСТО "КОНЕЦЦИКЛА" ДОЛЖНО БЫТЬ "КОНЕЦЕСЛИ"

    так как в приведенном коде вижу только один цикл.
    • #3
    • 22.11.2017 14:08
    0
    да. нету одного конецесли
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться