Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к заданию: халява. как узнать GUID

    • #1
    • 21.06.2016 17:37
    0
    Господа, в регистре СоответствиеОбъектовДляОбмена есть поле СсылкаВДругойИБ, вида: {"#",849ec10b-fe50-45eb-8aac-a007ccd72da8,47:a537d49a20be808811e637ada5910bb7} Как по ней определ...  Подробнее>>
    • #2
    • 21.06.2016 20:08
    0
     Процедура КнопкаВыполнитьНажатие(Кнопка)
    	
    	Попытка
    	
    		ГУИД = СсылкаНаОбъект.УникальныйИдентификатор();
    		
    	Исключение
    		
    	КонецПопытки;
    	
    КонецПроцедуры
    
    Функция ПолучитьСсылкуНоМенеджеруОбъекта(ОбъектыМенеджер,УникальныйИдентификатор)
    	
    	Для Каждого Менеджер Из ОбъектыМенеджер Цикл
    		
    		СсылкаНаОбъект = Менеджер.ПолучитьСсылку(УникальныйИдентификатор);
    		
    		Если СсылкаНаОбъект.ПолучитьОбъект() <> Неопределено Тогда
    			
    			Возврат Истина;
    			
    		КонецЕсли;
    		
    	КонецЦикла;
    	
    	Возврат Ложь;
    	
    КонецФункции
    
    Процедура ОсновныеДействияФормыПолучитьСсылку(Кнопка)
    	
    	Попытка
    		
    		УникальныйИдентификатор = Новый УникальныйИдентификатор(ГУИД)
    		
    	Исключение
    		
    		Возврат;
    		
    	КонецПопытки;
    	
    	// все объекты по которым можно получить ссылку
    	Если ПолучитьСсылкуНоМенеджеруОбъекта(Справочники,УникальныйИдентификатор) Тогда
    	ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(Документы,УникальныйИдентификатор) Тогда
    	ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(ПланыВидовХарактеристик,УникальныйИдентификатор) Тогда
    	ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(ПланыСчетов,УникальныйИдентификатор) Тогда
    	ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(ПланыОбмена,УникальныйИдентификатор) Тогда
    	ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(БизнесПроцессы,УникальныйИдентификатор) Тогда
    	ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(Задачи,УникальныйИдентификатор) Тогда
    	КонецЕсли;
    	
    КонецПроцедуры
    
    Процедура ОсновныеДействияФормыПолучитьСсылкуПоГУИД(Кнопка)
    	
    	Если СокрЛП(ГУИДИнверсный) = "" Тогда
    		
    		Возврат;
    		
    	КонецЕсли;
    	
    	ГУИДИнверсныйСтр = СтрЗаменить(ГУИДИнверсный,"0x","");
    	
    	// всего в ГУИД 36 символов, из них 4е "-"
    	// в инверсном ГУИД 1С 32 символа
    	ГУИД = Сред(ГУИДИнверсныйСтр,25,8)+"-"+Сред(ГУИДИнверсныйСтр,21,4)+"-"+Сред(ГУИДИнверсныйСтр,17,4)+"-"+Сред(ГУИДИнверсныйСтр,1,4)+"-"+Сред(ГУИДИнверсныйСтр,5,12);
    	
    	ОсновныеДействияФормыПолучитьСсылку(Кнопка);
    	
    КонецПроцедуры
    


    Как один из способов.
    • #3
    • 21.06.2016 22:02
    0
    А за такое у нас не банят?
    • #4
    • 21.06.2016 22:10
    0
    Ермолаев Вадим Анатольевич
    А за такое у нас не банят?


    за что банить?
    • #5
    • 21.06.2016 22:49
    • Отредактировано: 21.06.2016 22:50:46
    +1
    Да вроде за деньги работаем, для бесплатных консультаций тут отдельный раздел. Хочется сделать, оставь предложение как все нормальные люди. Нет возможности, купи проф. аккаунт. А отнимать таким образом, деньги у коллег по цеху, я считаю, обычным неуважением. А если дальше копнуть, то из за этих действий, не будет завершена сделка и ресурс, тоже теряет прибыль.
    • #6
    • 21.06.2016 22:55
    0
    Ермолаев Вадим Анатольевич
    Да вроде за деньги работаем, для бесплатных консультаций тут отдельный раздел. Хочется сделать, оставь предложение как все нормальные люди. Нет возможности, купи проф. аккаунт. А отнимать таким образом, деньги у коллег по цеху, я считаю, обычным неуважением. А если дальше капнуть, то из за этих действий, не будет завершена сделка и ресурс, тоже теряет прибыль.

    Когда будет на ресурсе профсоюз программистов, тогда такие высказывания, возможно, будут иметь вес.
    А так - можно разве что тапками закидать подсказчика. Судя по его комментариям, это "человек форумов", и на биржах нет опыта работы. Поэтому можно просто отнестись более лояльно, и объяснить, что "так делать нельзя". Прежде, чем призывать к публичной казни.
    • #7
    • 21.06.2016 23:46
    0
    Николай
    Прежде, чем призывать к публичной казни.


    Да я спросил всего лишь.
    • #8
    • 23.06.2016 12:18
    0
    Тип объекта насколько известен? Обработка должна работать во второй базе или тянуться по ОЛЕ?
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться