Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Написание отчета

    • #1
    • 06.08.2012 10:17
    • Отредактировано: 06.08.2012 14:35:34
    0
    //*******************************************
    Процедура Сформировать()
    	Запрос = СоздатьОбъект("Запрос");                                   
    	
    	ТекстЗапроса =
    	"//{{ЗАПРОС(Печать)
    	|Ном = Справочник.Номенклатура.ТекущийЭлемент;
    	|Количество = Регистр.ОстаткиТМЦ.Количество;
    	|Цены = Справочник.Цены.ТекущийЭлемент;       
    	|Группировка Ном;
    	|Функция Кол = КонОст(Количество);
    	|Условие (Ном.Родитель.Код = ""0092"");
    	|"//}}ЗАПРОС               
    	;
    	
    	Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    		Возврат;
    	КонецЕсли;
    	
    	Пока Запрос.Группировка("Товар") = 1 Цикл
    	    Сообщить(Запрос.Товар.Номенлкатура.Наименование);
    	КонецЦикла;
    	
    КонецПроцедуры




    Вылетает ошибка: ---------------------------

    1С:Предприятие

    ---------------------------

    Значение не представляет агрегатный объект (Родитель): 2

    ---------------------------

    ОК

    ---------------------------
    • #2
    • 22.08.2012 11:49
    0
    Добрый день! Какой то странный запрос. Что вы хотели им получить? Если остатки так будет правильнее
    	ТекстЗапроса = 
    	"//{{ЗАПРОС(Сформировать)
    	|Период с ВыбНачПериода по ВыбКонПериода;
    	|Без итогов;
    	|Номенклатура = Регистр.ОстаткиТМЦ.Номенклатура;
    	|Количество = Регистр.ОстаткиТМЦ.Количество;
    	|Функция КоличествоКонОст = КонОст(Количество);
    	|Группировка Номенклатура;
    	|Условие(Номенклатура в ВыбНоменклатура);
    	|"//}}ЗАПРОС
    	;
    

    где ВыбНоменклатура - группа на форме,
    ВыбНачПериода - период на форме
    • #3
    • 25.08.2012 07:57
    0
    При переборке справочника номенклатуры у карточки не было найдено поле родитель. Карточка просто первая по уровню..А запрос действительно странный.
    • #4
    • 31.08.2012 11:09
    0
    Спасибо за ответы! в 1с ке недавно, это был проверочный запрос, я его уже давно переделал.В итоге почти как у jemiazza написал без условий.
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться