Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к заданию: скрипт для запуска всех найденных exe файлов в указанной папке и ее подпапках с паузой 10 сек

    • #1
    • 22.05.2016 12:44
    0
    скрипт для запуска всех найденных exe файлов в указанной папке и ее подпапках с паузой 10 сек. то есть , есть папка с дистрибутивами 1с 8. скриншот прилагаю. в каждой папке есть исполняемый фа...  Подробнее>>
    • #2
    • 22.05.2016 12:44
    0
    вам на 1с накидать ? :)
    • #3
    • 22.05.2016 13:04
    0
    думаю, загвоздка еще может оказаться в том, что после распаковки могут появиться новые EXE

    если воспримите не как шутку - накидать это дело на 1с - вполне реально

    скачала запомнить при вложенном поиске все пути до EXE - потом их обработать
    • #4
    • 22.05.2016 13:06
    0
    с коммандной строкой и скриптами давно не общался
    • #5
    • 22.05.2016 13:09
    0
    удивительный перс
    Николай
    с коммандной строкой и скриптами давно не общался

    а чего отписываться то?
    • #6
    • 22.05.2016 13:15
    0
    Чайкин Игорь Александрович
    удивительный перс
    Николай
    с коммандной строкой и скриптами давно не общался

    а чего отписываться то?


    сайт 1сLancer (1CCCCC)

    и не надо впустую в дискуссию вступать

    так можно и туда:

    https://yandex.ru/search/?msid=1463912103.55561.22908.5307&text=%D0%BD%D0%B0%D0%BF%D0%B8%D1%81%D0%B0%D0%BD%D0%B8%D0%B5%20%D1%81%D0%BA%D1%80%D0%B8%D0%BF%D1%82%D0%BE%D0%B2%20%D0%B4%D0%BB%D1%8F%20%D0%BD%D0%B0%D1%87%D0%B8%D0%BD%D0%B0%D1%8E%D1%89%D0%B8%D1%85&suggest_reqid=5604533143166677919809701923096
    • #7
    • 22.05.2016 13:17
    • Отредактировано: 22.05.2016 13:18:01
    0
    Николай
    не надо впустую в дискуссию вступать


    с этим согласен. и именно по этому!
    если у вас нет готового решения, зачем флудить то?
    • #8
    • 22.05.2016 13:21
    0
    на 1с решение делается за 15 минут с перекурами

    начало вот:

    Процедура КнопкаВыполнитьНажатие(Кнопка)

    Если ПустаяСтрока(СокрЛП(ВыбПуть)) Тогда
    Предупреждение("Не указан начальный путь !");
    Возврат;
    КонецЕсли;

    МассивФайлов=НайтиФайлы(ВыбПуть,"*.EXE",Истина);

    // тут обходим массив и запускаем файлы через
    // КомандаСистемы или ЗапуститьПриложение

    КонецПроцедуры

    Процедура ВыбПутьНачалоВыбора(Элемент, СтандартнаяОбработка)

    Диалог=Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
    Диалог.Заголовок="Выберите начальный путь";

    Если Диалог.Выбрать() Тогда
    ВыбПуть=Диалог.Каталог;
    КонецЕсли;

    КонецПроцедуры
    • #9
    • 22.05.2016 13:24
    0
    Николай
    на 1с решение делается за 15 минут с перекурами


    теперь вопрос - если есть наработки, зачем писать что-то в обсуждении?
    так и напишите - 1ч, 700р в отзыве

    если это чужой код и боитесь - то зачем писать в обсуждении?
    • #10
    • 22.05.2016 13:28
    0
    нет - код не чужой - вот накидал ради интереса.

    попробую отзыв оставить
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться