Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Обсуждение к заданию: Внутренний штрих код без контрольного 13-го числа

    • #1
    • 10.02.2016 17:24
    0
    Требуется в УТ 11.2.2.116 при создании внутреннего штрих кода записывалось 12 символов кода без конторольного 13 числа ean13  Подробнее>>
    • #2
    • 10.02.2016 19:33
    0
    Наверное, чтоб не только записывалось, но и когда читалось - находило шк с 12 символами!?
    • #3
    • 11.02.2016 02:50
    0
    Сканер уже настроен на игнорирование 13го символа, зашло большое количество номенклатуры из другой программы с 12 символами, штрих код печатается 13, считывается 12 и ищет в базе все ок, а вот новые с 13 забисанными символами в карточке не находит так как при сканировании считывает только 12
    • #4
    • 11.02.2016 02:55
    0
    ну на крайний случай создать обработку которая создаст контрольную сумму в штрих кодах
    • #5
    • 11.02.2016 06:41
    • Отредактировано: 11.02.2016 07:15:53
    0
    Самое простое решение, это добавить контрольный символ к неправильным штрихкодам.
    Функция КонтрольныйСимволEAN(ШтрихКод, Тип) Экспорт
    
    	Четн   = 0;
    	Нечетн = 0;
    
    	КоличествоИтераций = ?(Тип = 13, 6, 4);
    
    	Для Индекс = 1 По КоличествоИтераций Цикл
    		Если (Тип = 8) и (Индекс = КоличествоИтераций) Тогда
    		Иначе
    			Четн   = Четн   + Сред(ШтрихКод, 2 * Индекс, 1);
    		КонецЕсли;
    		Нечетн = Нечетн + Сред(ШтрихКод, 2 * Индекс - 1, 1);
    	КонецЦикла;
    
    	Если Тип = 13 Тогда
    		Четн = Четн * 3;
    	Иначе
    		Нечетн = Нечетн * 3;
    	КонецЕсли;
    
    	КонтЦифра = 10 - (Четн + Нечетн) % 10;
    
    	Возврат ?(КонтЦифра = 10, "0", Строка(КонтЦифра));
    
    КонецФункции
    
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться