Информационный поток
Задания вакансии материалы разработки сообщения форума
Форум

Определить параметры макета в отчете

    • #1
    • 19.01.2016 12:09
    0
    Процедура КнопкаСформироватьНажатие(Кнопка)
    Перем остаток;
    ТабДок=Новый ТабличныйДокумент;
    Макет=Отчеты.Проба.ПолучитьМакет("Макет");
    Запрос= Новый Запрос;
    Запрос.Текст=
    "Выбрать
    |ХозрасчетныйОстатки.Счет,
    |ХозрасчетныйОстатки.СуммаОстаток
    |Из
    |РегистрБухгалтерии.Хозрасчетный.Остатки КАК ХозрасчетныйОстатки";
    Выборка = Запрос.Выполнить().Выбрать();
    Шапка=Макет.ПолучитьОбласть("Шапка");
    Стр=Макет.ПОлучитьОбласть("Строка");
    ТабДок.Очистить();
    ТабДок.ВЫвести(Шапка);
    Пока Выборка.Следующий() Цикл
    ?Счет=Выборка.ХозрасчетныйОстатки.Счет;
    ?Остаток=Выборка.ХозрасчетныйОстатки.СуммаОстаток;
    ТабДок.Вывести(Стр);
    //
    КонецЦикла;
    ТабДок.Показать();
    // Вставить содержимое обработчика.
    КонецПроцедуры
    Нужно вывести на печать отстатки по счетам. В макете определила 2 переменные счет и остаток как их получить и присвоить значение в цикле.
    • #2
    • 19.01.2016 12:17
    0
    Процедура КнопкаСформироватьНажатие(Кнопка)
    Перем остаток;
    
    ТабДок=Новый ТабличныйДокумент;
    Макет=Отчеты.Проба.ПолучитьМакет("Макет");
    
    Запрос= Новый Запрос;
    Запрос.Текст=
    "Выбрать
    |ХозрасчетныйОстатки.Счет КАК Счет,
    |ХозрасчетныйОстатки.СуммаОстаток КАК Остаток
    |Из
    |РегистрБухгалтерии.Хозрасчетный.Остатки КАК ХозрасчетныйОстатки";
    Выборка = Запрос.Выполнить().Выбрать();
    Шапка=Макет.ПолучитьОбласть("Шапка");
    Стр=Макет.ПОлучитьОбласть("Строка");
    ТабДок.Очистить();
    ТабДок.ВЫвести(Шапка);
    Пока Выборка.Следующий() Цикл
    //?Счет=Выборка.ХозрасчетныйОстатки.Счет;
    //?Остаток=Выборка.ХозрасчетныйОстатки.СуммаОстаток;
    Стр.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(Стр);
    //
    КонецЦикла;
    ТабДок.Показать();
    // Вставить содержимое обработчика.
    КонецПроцедуры
    • #3
    • 19.01.2016 12:20
    0
    Стр.Параметры.Счет=Выборка.ХозрасчетныйОстатки.Счет;
Яндекс-директ
Для участия в обсуждении Вам необходимо авторизоваться либо   зарегистрироваться