Информационный поток
Задания вакансии материалы разработки сообщения форума
Яндекс-директ

Старые обработки в новом (Управляемом) интерфейсе

  • Добавить свою разработку
 
Швабинский Валерий
Связаться с автором
16.08.2016 14:02:05
+1
Многие разработчики привыкли использовать какие либо обработки, разработанные для приложений с обычным интерфейсом.
Но они не работают в приложениях на управляемых формах. Как вариант, эту обработку можно включить в состав конфигурации, указать в свойствах конфигурации, что возможно использование обычных форм.
Скриншоты
Описание

 

Идея, как таковая, принадлежит не мне, а автору всем известной подсистемы "Инструменты разработчика" http://infostart.ru/public/15126/


Многие разработчики привыкли использовать какие либо обработки, разработанные для приложений с обычным интерфейсом. Но они не работают в приложениях на управляемых формах.


Как вариант, эту обработку можно включить в состав конфигурации, указать в свойствах конфигурации, что возможно использование обычных форм, и радоваться…

 

Но не всегда есть такая возможность, например если конфигурация стоит на поддержке.

 

Для таких случаев можно произвести небольшую модификацию внешней обработки.

Для этого необходимо через меню Сервис->Параметры на закладке общие указать, что будет использоваться режим запуска «Управляемое приложение и обычное приложение»

 

После чего станет возможным добавить в нашу обработку управляемую форму.

В самой форме размещаем команду, которая запустит нашу конфигурацию в режиме обычного приложения и автоматически откроет нашу обработку.

В обработчике команды прописываем код, который произведет запуск в обычном режиме.

 
&НаКлиенте
Процедура ЗапуститьОбычноеПриложение(Команда)
	
	#Если ВебКлиент Тогда
		Сообщить("Команда недоступна веб клиенте");
	#Иначе
		ПараметрыЗапуска = "";
		СтрокаСоединения = СтрокаСоединенияИнформационнойБазы();
		ПараметрыЗапуска = ПараметрыЗапуска + " ENTERPRISE";
		ПараметрыЗапуска = ПараметрыЗапуска + " /IBConnectionString""" + СтрЗаменить(СтрокаСоединения, """", """""") + """";
		ПараметрыЗапуска = ПараметрыЗапуска + " /RunModeOrdinaryApplication";
		ИспользуемоеИмяФайла = ПолучитьИспользуемоеИмяФайла(ИмяКомпьютера());
		Если ЗначениеЗаполнено(ИспользуемоеИмяФайла) Тогда
			ПараметрыЗапуска = ПараметрыЗапуска + " /Execute""" + ИспользуемоеИмяФайла + """";
		КонецЕсли; 
		ЗапуститьПриложение(КаталогПрограммы() + "1cv8.exe " + ПараметрыЗапуска);
	#КонецЕсли 
	
КонецПроцедуры

&НаСервере Функция ПолучитьИспользуемоеИмяФайла(ИмяКомпьютера) Если ИмяКомпьютера = ИмяКомпьютера() Тогда Возврат РеквизитФормыВЗначение("Объект").ИспользуемоеИмяФайла; Иначе Возврат Неопределено; КонецЕсли; КонецФункции


Радуемся инструменту, который не раз выручал и еще не раз выручит. )


Ключевые слова:   внешняя обработка   обработка для управляемого приложения   обычные формы   Управляемая форма   обычное приложение
Файлы для скачивания
0
    ≡ к списку разработок