Информационный поток
Задания вакансии материалы разработки сообщения форума
Яндекс-директ

Оповещение пользователей 1С (сообщения между пользователями, уведомления, управляемое и обычное приложение)

  • Добавить свою разработку
 
Сюраев Алексей
Связаться с автором
27.07.2016 21:11:31
0
Разработка предназначена для уведомления пользователей как выборочно так и всех, так же можно просто писать сообщения или вести переписку между пользователями.
Скриншоты
Описание
В организации около 300 пользователей 1С и 6 конфигураций 1С управляемых и обычных. При работе иногда возникают ситуации когда нужно уведомить пользователей о технических работах, обновлениях и доработках, о необходимости завершить работу, сразу или например вечером к 20:00. Обзванивать или писать письма не эффективно. Оповещение через Active Directory очень маленькое его легко не заметить, так же отвлекает пользователей домена не использующих в работе 1С. Поэтому возникла необходимость разработать систему оповещений пользователей с минимальными изменениями всех конфигураций, подходящую для управляемых и обычных форм, и сообщениями, которые нельзя пропустить.


Разработка представляет собой регистр сведений и изменение в модуле управляемого или обычного приложения.
Для запуска оповещения необходимо добавить запись в регистр сведений, пользователи будут получать уведомления в период указанный между началом и концом времени оповещения.

УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ


ОБЫЧНОЕ ПРИЛОЖЕНИЕ



Окно оповещения показываемое в программе пользователя блокирует весь интерфейс и пользователи работающие в данный момент в программе не пропустят оповещение и соответственно прочитают.

УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ


ОБЫЧНОЕ ПРИЛОЖЕНИЕ


Список регистра

В списке оповещений можно просмотреть кому доставлено оповещение и кто прочитал.

УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ



ОБЫЧНОЕ ПРИЛОЖЕНИЕ




Для внедрения разработки в свою конфигурацию необходимо:

  1. Установить возможность редактирования конфигурации.
  2. Сравнить с конфигурацией поставляемой в данной публикации. Будет добавлен регистр сведений "ОповещенияПользователей" и запись в модуле обычного или управляемого приложения, в зависимости от основного режима запуска приложения.

    Запись модуля обычного или управляемого приложения различаются:


    УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ
Процедура ПриНачалеРаботыСистемы() //Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю) //Подходить для всех конфигураций ПодключитьОбработчикОжидания("modОбработчикОбработкиОповещения", 60); КонецПроцедуры // ПриНачалеРаботыСистемы() //Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю) //Подходить для всех конфигураций //Вызов обработчика ожидания продолжается пока форма не будет закрыта  //или пока не будет вызван метод формы Процедура modОбработчикОбработкиОповещения() Экспорт СообщениеПользователю = ПолучитьФорму("РегистрСведений.ОповещенияПользователей.Форма.ФормаОтправкиУпр").ПолучитьСообщенияОбработкиОповещения(); Если Не СообщениеПользователю = Неопределено Тогда Форма = ПолучитьФорму("РегистрСведений.ОповещенияПользователей.Форма.ОповещениеУпр"); Если Не Форма.Открыта() Тогда ЗаполнитьЗначенияСвойств(Форма,СообщениеПользователю,,"ТолькоПросмотр"); Форма.Открыть(); Иначе Форма.Активизировать(); КонецЕсли; КонецЕсли; КонецПроцедуры ОБЫЧНОЕ ПРИЛОЖЕНИЕ Процедура ПриНачалеРаботыСистемы() //Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю) //Подходить для всех конфигураций ПодключитьОбработчикОжидания("modОбработчикОбработкиОповещения", 60); КонецПроцедуры // ПриНачалеРаботыСистемы() //Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю) //Подходить для всех конфигураций //Вызов обработчика ожидания продолжается пока форма не будет закрыта  //или пока не будет вызван метод формы Процедура modОбработчикОбработкиОповещения() Экспорт СообщениеПользователю = РегистрыСведений.ОповещенияПользователей.ПолучитьСообщенияОбработкиОповещения(); Если Не СообщениеПользователю = Неопределено Тогда Форма = ПолучитьФорму("РегистрСведений.ОповещенияПользователей.Форма.ОповещениеОбыч"); Если Не Форма.Открыта() Тогда ЗаполнитьЗначенияСвойств(Форма,СообщениеПользователю,,"ТолькоПросмотр"); Форма.ОткрытьМодально(); Иначе Форма.Активизировать(); КонецЕсли; КонецЕсли; КонецПроцедуры 
Внедрение разработки бесплатно, производиться в течении 10 минут.

Бесплатная техподдержка в течении 30 дней.


Разработка предназначена для платформы 8.3, различных типовых и  нетиповых конфигураций, в режиме тонкого, толстого клиента и веб-клиента.
 

Возможна самостоятельная доработка, код открыт для редактирования.
 

Очень удобный вариант для оповещения, уведомления пользователей 1С об технических работах, доработках конфигураций, обновлениях, возможность вести переписку между пользователями 1С в рамках 1-й программы.
 

1) 100% доставка оповещений ко всем пользователям, в отличие от аналогов. 
2) Возможность отправки картинок.
3) Просмотр активности пользователей в списке сообщений (кому доставлено, кто прочитал).
4) Возможность написать ответ отправившему оповещение.
5) Не влияет на другие объекты, при обновлениях конфигураций, с установленной возможностью редактирования.

Ключевые слова:   Оповещение   уведомление   сообщения пользователям      1C   сочисофт   sochisoft
Файлы для скачивания
  • 500р
    • Оповещения 1.11.cf (1.17Mb)
    • Оповещение пользователей 1.11
    • Конфигурация для объединения "Оповещение пользователей 1.11"
    • дата загрузки: 27.07.2016 21:14:39
0
    ≡ к списку разработок