Информационный поток
Задания вакансии материалы разработки сообщения форума
Яндекс-директ

Акт об оказании услуг со скидками с факсимиле (сканом печати и подписи) для редакций УТ 11.1.10

  • Добавить свою разработку
 
Константин
Связаться с автором
17.09.2015 15:38:58
+1
Представляет собой модификацию внешней печатной формы Акта об оказании услуг (со скидками) для документа Реализация товаров и услуг типовой Управление торговлей 11.1.10.138 выводит факсимиле из настроек печати организации. Для опытных пользователей и начинающих программистов приведены рекомендации по модификации данной формы.
Скриншоты
Описание

По специфическому пожеланию одного из заказчиков добавить факсимиле во внешнюю печатную форму акта об оказании услуг для документа Реализация товаров и услуг (РТУ)  создаю данную доработку(оригинал с более подробной инструкцией по данной ВПФ тут, а также инструкцию  опытным заказчикам и начинающим программистом как сделать такую доработку в любой ВПФ самому. Самое главное, чтоб была поддержка этого самого факсимиле в справочнике "Организации" (как и логотипа для отдельных ВПФ в шапке документа).

ВНИМАНИЕ!!! ПО ПРЕДВАРИТЕЛЬНОЙ ЗАЯВКЕ (можно в комментариях внизу публикации) выполнятеся модификация данной печатной формы по полям, размеру (в т.ч. факсимиле) и прочим мелочам. Ниже инструкция как подправить самому если Вы опытный пользователь или начинающий программист.

 

КАК СДЕЛАТЬ ФАКСИМИЛЕ в бесплатной справке из УТ 11.1 внизу работы. 

Еще важно, данный акт печатается в той форме как приведен (за универсальностью обращайтесь в личке).

Ниже подробная инструкция как что сделать чтоб печатало:

Изображение

Штатный механизм УТ 11.1 как добавить факсимиле и логотип для организации.

Изображение

Файл с примером скана подписи (из открытых источников в интернете).

 

Изображение

 Результат печати в УТ 11.1.

Если нужно растянуть факсимиле (нет увы под руками сканера увы) то макет данной печатной формы нужно открыть в конфигураторе и растянуть до нужных размеров не меняя признаки "пропорциональность" в свойствах рисунка.

 

Ниже даны рекомендации для опытных пользователей (У ИП обычно нет денег на мелкие доработки), а также начинающих программистов из рубрики "сделай сам".

Изображение

1. Открываем нашу ВПФ в конфигураторе

Изображение

2. Открываем макет для редактирования

Изображение

 3. Изменяем размер и подгоняем под нужный нам формат вывода.

На этом все трудности для пользователя заканчиваются. Ниже просто приводится фрагмент для программистов как вывести картинку в макет:

 

 // Фрагмент вывода области печати 
ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
ДобавитьФаксимиле(ДанныеПечати, ОбластьМакета);
ТабличныйДокумент.Вывести(ОбластьМакета);


Процедура ДобавитьФаксимиле(ПарПечати, Обл)
	//Доработка для печати факсимиле в Акт
	Попытка
		Орг = ПарПечати.Организация;
		ФайлКартинки = ОбщегоНазначения.ПолучитьЗначениеРеквизита(Орг, "ФайлФаксимильнаяПечать");
		Если Не ЗначениеЗаполнено(ФайлКартинки) Тогда
			Возврат;
		КонецЕсли;
		ДвоичныеДанныеФайла = ПрисоединенныеФайлы.ПолучитьДвоичныеДанныеФайла(ФайлКартинки);
		
		Если ТипЗнч(ДвоичныеДанныеФайла) = Тип("Картинка") Тогда
			Картинка = ДвоичныеДанныеФайла;
		ИначеЕсли ТипЗнч(ДвоичныеДанныеФайла) = Тип("ДвоичныеДанные") Тогда
			Картинка = Новый Картинка(ДвоичныеДанныеФайла);
		Иначе
			Картинка = Новый Картинка;
		КонецЕсли; 
		
		Обл.Рисунки.Подпись.Картинка = Картинка; // Самое важное вот!!!
		
	Исключение
		СП = Новый СообщениеПользователю;
		Релиз = СокрЛП(Метаданные.Версия);
		СП.Текст = "В текущем релизе УТ "+Релиз+" не предусмотрена печать факсимиле. Подробно "+ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() );
		СП.Сообщить();
	КонецПопытки;
	// конец доработки
КонецПроцедуры

 

 

Также по предварительной заявке можно будет поставить фамилии и инициалы исполнителей из документов и прочие доработки.

 

Примечание. Для редакций  с УТ 11.0 по УТ 11.1.5 (или до УТ 11.1.7) где нет поддежки ни факсимиле ни логотипа по организации! За отдельную денюжку готов доработать данную (и любую другую) внешнюю печатную форму чтоб по каждой организации ФАКСИМИЛЕ, ЛОГОТИП и ЛЮБАЯ ДРУГАЯ ГРАФИКА могла задаваться и изменяться ПОЛЬЗОВАТЕЛЕМ перед печатью САМОМОСТОЯТЕЛЬНО (см. работу по

Товарному чеку для  УТ 11.1)http://www.1clancer.ru/catalog/2069 .

Преимущество для заказчика НЕ НУЖНО КАЖДЫЙ РАЗ ОБРАЩАТЬСЯ К ПРОГРАММИСТАМ. Как поправить размеры и вывод при отсутствии финансов можно научиться самому по приведенным скриншотам. 

Еще примечание: данная доработка является гм "управленческой" и не приветствуется налоговыми органами. Все на Ваше усмотрение.

Первоисточник моя публикация http://www.1clancer.ru/catalog/2046 и механизм хранения графики для ранних редакций УТ 11.1 "Товарный Чек с логотипом организации" для УТ 11.0, УТ 11.1.0-УТ 11.1.10 http://www.1clancer.ru/catalog/2069 

По всем неточностям и недоработкам пишите будет исправлено. Также принимаются пожелания для дальнейших модификаций и прочих графических "причуд". 

Ключевые слова:   Акт об оказании услуг   факсимилье   подпись   печать   графика в ВПФ   задание пользователем факсимилье   печать   Акт   УТ 11.1   управление торговлей   как сделать ВПФ самому   как добавить печать в ВПФ самому   разработка ВПФ   печатные формы   печать   офисные документы   управление торговлей   управленческий учет   печатная форма Акта об оказании услуг   как добавить поле подписи   скан подписи   как сделать факсимиле
Файлы для скачивания
  • 499р
    • ВПФ_АктОбОказанииУслуг_С_Факсимилье.epf (36Kb)
    • Акт об оказании услуг с факсимиле (подпись и печать) для УТ 11.1.10
    • Подставляет рисунок подписи и печати из хранимых графических файлов факсимиле конфигурации управление торговлей релиза УТ 11.1.10 в печатную форму Акта об оказании услуг. Все подробно расписано как сделать самому.
    • дата загрузки: 17.09.2015 15:58:28
    • скачиваний: 305
    • дата загрузки: 17.09.2015 16:01:02
Скачать все файлы одним архивом (146Kb)
0
    ≡ к списку разработок