Информационный поток
Задания вакансии материалы разработки сообщения форума
Яндекс-директ

ВДГБ: Ломбард 3.3 Доработки учета и печати залогового билета (БО-7) и договоров залога ПТС (автотранспорт).

  • Добавить свою разработку
 
Константин
Связаться с автором
06.08.2015 07:01:37
+1
ВДГБ Ломбард, редакция 3.3 (3.3.36.1). Надеюсь, кому-то могут быть полезными наработки по изменению конфигурации, механизм печати ВПФ (залоговый билет БО-7, договор залога ПТС) и методика внесения изменений в конфигурацию ВДГБ (да и вообще работе с этой конфигурацией).
Также тема была поднята на форуме ранее "Правильная модификация решения: механизм учета доп. характеристик и свойств, надстройки к механизму внешних печатных форм Залоговый билет БО-7, договора залога".
Скриншоты
Описание

Для РАЗРАБОТЧИКОВ (кому выпадет "счастье"): отраслевая модификация программы ВДГБ Ломбард Х.ХХ.ХХ Здесь представлены доработки конфигурации согласно нижеприведенным материалам а статье, а также модифицированные печатные формы (которые принципиально невозможно вытащить из конфигурации, т.к. она завязаны на данные документов, в т.ч. на пересчет процентов. Самое оптимальное создать кнопки и выводить через процедуру печати - так проще найти ошибку, отладить и по-минимуму не приостанавливать работу. Своеобразный "печаный механизм" с использованием стандартного справочника "Внешние обработки" - ВДГБ ломбард выполнен на базе типового релиза Бухгалтерия предприятия 2.0.

Также в случае каких-либо вопросов можно показать что такое отраслевые конфигурации непосредственному заказчику и почему по ним такие цены, качество работы и сроки выполнения доработок.

В публикации предоставлены НАРАБОТКИ по данному решению (для запуска необходимо 99% мелкая модификация всего под текущий релиз):

 

В продолжении темы поднятой ранее на форуме "Правильная модификация решения: механизм учета доп. характеристик и свойств, надстройки к механизму ВПФ Залоговый билет" по данному отраслевому решению выкладываю свои наработки (требующие серьезной отладки под Ваше решение). Камнем преткновения стала печатная форма Залогового билета. Особенность в том, что сам документ содержит очень много специфических данных, рассчитываемых по алгоритмам самого документа. Естественно, что все это дело вытащить без потерь функциональности без ошибок проблематично. Я поступил так:

1. Создал панель кнопок в документе (см рисунок 1).

Рисунок 1 - кнопки документа

 

2. Вставил в конфигурацию нижеприведенный код: 

//###Дор+

//Описание доработки: Вызов ВПФ для печати:
Процедура ДействияФормыпДоговорЗалога(Кнопка)
    ПечатьИзВПФ("ВДГБ_ВПФ_ДоговорЗалога"); // Приходится передавать ДокументОбъект!
КонецПроцедуры

Процедура ДействияФормыпЗалоговыйБилет(Кнопка)    
    ПечатьИзВПФ("ВДГБ_ВПФ_ЗалоговыйБилет"); // Приходится передавать ДокументОбъект!
КонецПроцедуры

Процедура ДействияФормыпДоговорЗайма2014(Кнопка)    
    ПечатьИзВПФ("ВДГБ_ВПФ_ДоговорЗайма2014"); // Приходится передавать ДокументОбъект!
КонецПроцедуры

Процедура ДействияФормыпДоговорЗалогаПТС(Кнопка)
    ПечатьИзВПФ("ВДГБ_ВПФ_ДоговорЗалогаПТС"); // Приходится передавать ДокументОбъект!
КонецПроцедуры


// Описание доработки: Вызывает данные функции из справочника ВПФ по строгому соответствию имени и передает им объект.
Процедура ПечатьИзВПФ(ИмяВПФ);
    СсылкаНаВПФ = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяВПФ);
    Если СсылкаНаВПФ.Пустая() Тогда
        Сообщить("В справочнике 'Внешние обработки' не нашли внешнюю печатную форму с наименованием '"+ИмяВПФ+"'");
        Возврат;
    КонецЕсли;
        
    Попытка
        ИмяВременногоФайла = КаталогВременныхФайлов()+"тмп_впф.epf";
    Исключение
        Сообщить ("Невозможно создать файл обработке в каталоге временных файлов <<"+
        +КаталогВременныхФайлов()+">>. Возможно, не хватает прав доступа в Windows в папку для данного сеанса 1С ");
        Возврат;
    КонецПопытки;    
    
    ДвоичныеДанные = СсылкаНаВПФ.ХранилищеВнешнейОбработки.Получить();        
    ДвоичныеДанные.Записать(ИмяВременногоФайла);
    
    Попытка
        ОбрОбъект = ВнешниеОбработки.Создать(ИмяВременногоФайла);
        ОбрОбъект.ДокОбъект = ЭтотОбъект; // НЕ исп. метод скопировать. Передать ТАК - особенности ВДГБ;
    Исключение
        Сообщить("Ошибка создания объекта из временного файла обработки "+ИмяВременногоФайла);
        Возврат;
    КонецПопытки;
    
    // Проба печати
    Попытка
        ТаблДок = ОбрОбъект.Печать();
        ТаблДок.Вывести();
    Исключение
        А=1; // Точка останова для отладки!
        Сообщить(ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() )); // ВНЕШНЮЮ печатную форму из справончика ВПФ можно спокойно поправить!
    КонецПопытки;    
            
КонецПроцедуры    
//###Дор- 

3. Создал "с нуля" ВПФ для залогового билета (и параллельно обычные ВПФ договоров ПТС и прочих без использования данного механизма (фрагменты тут в статье и приложениях в виде объектов конфигурации в *.cf и внешних отчетов и обработок. 

4. По залоговым вещам (вроде) добавил регистр сведений и еще что-то(см рисунки 2 и 3 по объектам учета)...


Рисунок 2 - вариант 1 с регистором сведений

Рисунок 3 - вариант 2 с регистром сведений

Далее, фрагменты кода из конфигурации:

 
Перем мУчетнаяПолитикаЛомбарда Экспорт; // Хранит настройки учетной политики ломбарда.

Перем мДокументОбъект Экспорт; // Хранит объект вызвавшего документа. СЮДА передадим для ЗалоговогоБИЛЕТА!

Перем мВалютаРегламентированногоУчета; // Хранит значение константы "Валюта регламентированного учета"

Перем мДанныеКредитования; 

Перем мСхема;

///Перем СсылкаНаОбъект;

//---------------

//---------------


Функция ПолучитьУсловияПоСхемеКредитования()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.Период,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.СхемаКредитования,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ИзмерениеКредита,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ИзмерениеХранения,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ИзмерениеПросрочки,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ИзмерениеОценки,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ИзмерениеСнятияСРеализации,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ПериодКредита,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ПериодХранения,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ПериодПросрочки,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ВариантРасчетаСуммыЗаКредит,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ВариантРасчетаСуммыЗаХранение,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ВариантРасчетаСуммыЗаОценку,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ВариантРасчетаСуммыЗаПросрочку,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ЗаКредит,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ЗаХранение,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ЗаПросрочку,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ЗаОценку,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ЗаСнятиеСРеализации,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ОграничениеНачисленияЗаКредит,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.МинимальныйСрокКредит,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.МинимальныйСрокХранение,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.МинимальнаяСуммаКредит,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.МинимальнаяСуммаХранение,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ОснованиеРасчетаКредита,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ОснованиеРасчетаХранения,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ОснованиеРасчетаПросрочки,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ОснованиеРасчетаОценки,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.ОснованиеРасчетаСнятияСРеализации,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.УдалитьОтСуммыСсудыКредит,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.УдалитьОтСуммыСсудыХранение,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.УдалитьОтСуммыСсудыПросрочку,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.УдалитьОтСуммыСсудыОценку,
 | ЛМБ_УсловияПредоставленияКредитаСрезПоследних.УдалитьОтСуммыСсудыСнятиеСРеализации
 |ИЗ
 | РегистрСведений.ЛМБ_УсловияПредоставленияКредита.СрезПоследних(&ДатаДок, СхемаКредитования = &Схема) КАК ЛМБ_УсловияПредоставленияКредитаСрезПоследних";
    Запрос.УстановитьПараметр("ДатаДок", ДокОбъект.Дата);
    Запрос.УстановитьПараметр("Схема", ДокОбъект.СхемаКредитования);
    
    Результат = Запрос.Выполнить();
    Если Результат.Пустой() Тогда
        Сообщить("Ошибка получения схемы кредитования для документа (схема не установлена в документе) "+ДокОбъект);
        ВызватьИсключение("Ошибка получения схемы кредитования для документа"+ДокОбъект);
        Возврат Неопределено;
    КонецЕсли;
    
    Выборка = Результат.Выбрать();
    Выборка.Следующий(); // Точно есть один!
    
    Возврат Выборка;
    
КонецФункции    

Функция ПолучитьПроцентПоКредиту()
    Возврат мСхема.ЗаКредит;       
КонецФункции    

Функция ПолучитьПроцентЗаХранение()
    Возврат мСхема.ЗаХранение;
КонецФункции


Функция ПолучитьСтруктуруХарактеристикВещи (Вещь)
    Стр = Новый Структура("Имя, Значение"); // Имя и значение характерискик АВТО (если они есть)
    Если ТипЗнч(Вещь) <> Тип("СправочникСсылка.ЛМБ_ЗалоговыеВещи") Тогда
        Возврат Стр; // не тот тип 
    КонецЕсли;    
    
    Если Вещь.ПустаяСсылка() Тогда
        Возврат Стр; // пустая
    КонецЕсли;    
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ
 | ЗначенияСвойствОбъектов.Значение,
 | ЗначенияСвойствОбъектов.Свойство КАК ДопРеквизит
 |ИЗ
 | РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
 |ГДЕ
 | ЗначенияСвойствОбъектов.Объект = &Вещь
 | И НЕ ЗначенияСвойствОбъектов.Свойство.ПометкаУдаления";
    Запрос.УстановитьПараметр("Вещь", Вещь);
    Результат = Запрос.Выполнить();
    Если Результат.Пустой() Тогда
        Возврат Стр; // Пусто или прав не хватило для прочтения(маловероятно) - тогда для ошибки периода исп. убрать РАЗРЕШЕННЫЕ
    КонецЕсли;    
    
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
        Стр.Вставить(Выборка.ДопРеквизит, Выборка.Значение);
    КонецЦикла;    
    
    Возврат Стр;
    
КонецФункции    

Функция ХарактеристикиВещиТекстомВВидеСписка (Вещь)
    стр = ""; // На выходе Марка машины: ГАЗ + переносСтроки и.т.д.
    Структ = ПолучитьСтруктуруХарактеристикВещи(Вещь);
    
    Если Структ.Количество() = 0 Тогда
        Возврат стр; // Вернем пустую строку
    КонецЕсли;
    
    Для каждого ЭлемСтр Из Структ Цикл
        Стр = Стр + ЭлемСтр.Ключ +": "+ЭлемСтр.Значение+Символы.ПС;
    КонецЦикла;    
    
    Возврат Стр;
    
КонецФункции    

 

Зачем ТАК спросите Вы? ВПФ все-таки проще править и заменить, чем лезть в конфигурацию. Хотя именно залоговый билет с глюками и пригодится как строительный материал программистам, которым по долгу службы в принудительном порядке или уже добровольно придется дорабатывать ТАКОЕ отраслевое решение.  Печатные формы кроме залогового билета (по ней основная сложность) могут быть работоспособны. 

Надеюсь, данная методика и материалы могут пригодиться.

P.S. Ниже буду приводить редкие материалы, посвященные разработе по данной тематике

- интересное решение http://infostart.ru/public/205109/ - Подбор залоговых вещей в документ "Подготовка к продаже" в конфигурации "ВДГБ: Ломбард 3"

 

Внешний вид печатных форм для ВДГБ ломбард 3.3:

Изображение

1. Бланк-квитанция БО-7 ВДГБ Ломбард

 

 2. Текст договора (привожу для примера везде программно из разных условий в макеты в виду специфики отрасли:

 

// Текст договора
// Договор залога авто-ломбарда
//
//ДОГОВОР ЗАЛОГА № ОФ000000097
//Уфа
//Гр. РФ, Иванова Эльвира Тимерьяновна, дата рождения 23 марта 1986 г. (Паспорт гражданина Российской Федерации серия хх № уууууу выдан хх.хх.2ххх Мечетлинским РОВД Респ. Башкортостан код подр. ) действующий от своего имени, далее ЗАЛОГОДАТЕЛЬ и Петров Петр  Юрьевич (далее – ЛОМБАРД, ЗАЛОГОДЕРЖАТЕЛЬ), в лице Директора ООО "СУПЕР-ПУПЕР АВТОЛОМБАРД", действующего на основании устава и Правил пользования услугами Ломбарда, заключили настоящий договор, далее ДОГОВОР, о нижеследующем:
//1. ПРЕДМЕТ ДОГОВОРА
//1.1. ЗАЛОГОДАТЕЛЬ передает, а ЗАЛОГОДЕРЖАТЕЛЬ принимает в залог нижеследующее имущество в обеспечение краткосрочного кредита (далее – автомобиль):
//"Автомобиль марки: Toyota RAV4
//Год выпуска: 2013
//Идентификационный номер (VIN): JTMDХХХХХХХХ 
//кузов: № JTMDFХХХХХХХХХХХХ
//шасси (рама): Шасси
//Цвет кузова: белый
//Модель, № двигателя: 2ARХХХХХХХХХХ
//Государственный регистрационный знак: Е77ххххх
//Паспорт транспортного средства (ПТС): 78 УТ ххххх
//Свидетельство о регистрации ТС: 0ххх хххххх
//Особые отметки:"
//1.2. ЗАЛОГОДЕРЖАТЕЛЬ предоставляет ЗАЛОГОДАТЕЛЮ на срочной и возмездной основе краткосрочный кредит (далее - Кредит) на условиях, содержащихся в настоящем договоре и Правилах пользования услугами Ломбарда (далее – ПРАВИЛА)
//2. ПЕРЕДАЧА ЗАЛОГА
//"2.1. Передача залога оформляется Залоговым билетом, Заявлением, настоящим Договором, Актом-осмотра. Вместе с АТС передаются ключи от него, паспорт транспортного средства, свидетельство о регистрации АТС.
//2.2. Автолмобиль принимаются в залог в нормальном исправном состоянии, с учетом нормального износа в рамках эксплуатации."
//"2.3. ЗАЛОГОДАТЕЛЬ гарантирует, что какие-либо скрытые дефекты в автомобиле отсутствуют.
//2.4. Оценка закладываемого имущества производится по взаимному согласию сторон и указывается в Залоговом билете, настоящем Договоре и составляет 800 000,00 руб. "
//3. ВЫДАЧА КРЕДИТА
//3.1. ЗАЛОГОДЕРЖАТЕЛЬ выдает ЗАЛОГОДАТЕЛЮ кредит в размере 800 000,00 (Восемьсот тысяч рублей 00 копеек) руб.
//3.2. Кредит выдается на срок – 30 дн. (Тридцать дн.), с 07 октября 2014 г. по 05 ноября 2014 г. В случае если дата возврата кредита приходится на выходные (суббота, воскресенье), установленные в законном порядке нерабочие и праздничные дни, указанная дата возврата кредита переносится на непосредственно следующий рабочий день.
//3.3. В указанный срок ЗАЛОГОДАТЕЛЬ обязуется возвратить выданный ему кредит и оплатить услуги ЗАЛОГОДЕРЖАТЕЛЯ. По взаимному согласию сторон срок пользования кредитом может быть пролонгирован, при условии своевременной оплаты услуг ломбарда. В этом случае оформляется Дополнительное соглашение.
//3.4. Плата за пользование кредитом составляет – 76,30 % годовых от суммы кредита и берется кратно сроку, указанному в п.3.2. настоящего Договора. В льготный период (один календарный месяц с момента окончания срока возврата кредита) взимается плата за пользование кредитом кратно указанному сроку. Кроме этого ЗАЛОГОДАТЕЛЬ обязуется уплатить неустойку в размере 0,8 % от суммы займа за каждый просроченный день, начиная с даты, следующей за датой возврата кредита, указанной в залоговом билете, по дату фактического возврата кредита. Единовременная плата за пролонгацию срока пользования кредитом не взымается. Тарифы на другие услуги ЗАЛОГОДЕРЖАТЕЛЯ содержаться в ПРАВИЛАХ.
//4. ОБЯЗАННОСТИ ЗАЛОГОДЕРЖАТЕЛЯ
//"4.1. Предоставить ЗАЛОГОДАТЕЛЮ краткосрочный кредит наличными денежными средствами под залог Имущества.
//4.2. Обеспечить сохранность заложенного Имущества в течение всего срока залога.
//4.3. Застраховать за свой счет принятое в залог Имущество. "
//4.4. ЗАЛОГОДЕРЖАТЕЛЬ освобождается от ответственности за неисполнение обязательств по настоящему Договору, если это неисполнение явилось следствием действия обстоятельств непреодолимой силы. Под обстоятельствами непреодолимой силы понимаются: стихийные бедствия, наводнения, пожар,
//землетрясения, военные действия любого характера, массовые беспорядки, блокады, запрещения, а также изменения действующего законодательства и иные ограничения экономического и политического характера, объективно мешающие исполнению обязательств по настоящему Договору, которые ЗАЛОГОДЕРЖАТЕЛЬ не мог предвидеть или избежать разумным образом.
//"4.5. При наступлении указанных в пункте 4.4. обстоятельств, ЗАЛОГОДЕРЖАТЕЛЬ должен немедленно известить о них в письменной форме ЗАЛОГОДАТЕЛЯ.
//4.6. Возвратить ЗАЛОГОДАТЕЛЮ Имущество и документы, указанные в п.2.1. ДОГОВОРА, после возврата ЗАЛОГОДАТЕЛЕМ полученного кредита и полной оплаты услуг ЗАЛОГОДЕРЖАТЕЛЯ.
//4.7. Возместить в соответствии с ПРАВИЛАМИ ущерб ЗАЛОГОДАТЕЛЮ в случае утраты или повреждения по вине ЗАЛОГОДЕРЖАТЕЛЯ заложенного Имущества. Ответственность ЗАЛОГОДЕРЖАТЕЛЯ ограничивается размером оценочной стоимости Имущества, указанной в Залоговом билете. "
//5. ОБЯЗАННОСТИ ЗАЛОГОДАТЕЛЯ
//"5.1 . Выдать ЗАЛОГОДЕРЖАТЕЛЮ в лице администратора ломбарда , или другого должностного лица нотариально заверенную генеральную доверенность на закладываемое автотранспортное средство.
//5.2. Оплатить услуги ЗАЛОГОДЕРЖАТЕЛЯ в соответствии с настоящим ДОГОВОРОМ и ПРАВИЛАМИ.
//5.3. До истечения срока, установленного п. 3.2. настоящего Договора, ЗАЛОГОДАТЕЛЬ не вправе совершать отчуждение Имущества.
//5.4. Гарантировать, что на момент заключения настоящего договора, закладываемое автотранспортное средство не обременено залоговыми правами третьих лиц, не состоит под арестом, возместить ЗАЛОГОДЕРЖАТЕЛЮ понесенные убытки, в частности, сумму, недополученную вследствие удовлетворения требований предшествующих залогодержателей или других третьих лиц, в случае, если какие-либо обременения обнаружатся или возникнут после заключения настоящего договора."
//"5.5. Гарантировать, что на момент заключения настоящего договора ЗАЛОГОДАТЕЛЬ не привлечен судом в качестве ответчика по гражданскому делу связанному с имущественным спором, а также в отношении него не возбуждено уголовное дело. В течение двух суток, после того как станет известно уведомить в письменной форме ЗАЛОГОДЕРЖАТЕЛЯ, об участии ЗАЛОГОДАТЕЛЯ в суде в качестве ответчика по имущественным спорам, либо о возбуждении уголовного дела в отношении ЗАЛОГОДАТЕЛЯ.
//В течение 10 (десяти) календарных дней с момента прекращения права собственности на предмет залога по основаниям, предусмотренным законодательством РФ, или по иным основаниям, восстановить предмет залога или с согласия ЗАЛОГОДЕРЖАТЕЛЯ заменить его другим равноценным имуществом, равным по его стоимости. "
//6. ПРАВА ЗАЛОГОДЕРЖАТЕЛЯ
//"6.1. Налагать взыскание на заложенное Имущество без оповещения ЗАЛОГОДАТЕЛЯ, без совершения исполнительной надписи нотариуса или другом законном основании в случае невозвращения ЗАЛОГОДАТЕЛЕМ в установленный срок кредита или не внесения платы за услуги ЗАЛОГОДЕРЖАТЕЛЯ.
//6.2. Произвести удержание из суммы, полученной от реализации Имущества, в размере задолженности ЗАЛОГОДАТЕЛЯ (с учетом неустоек, пеней, штрафов и иных процентов по Договору)."
//7. ПРАВА ЗАЛОГОДАТЕЛЯ
//"7.1. В период действия ДОГОВОРА, льготного периода продлить срок кредита в соответствии с п.3.3 настоящего ДОГОВОРА, а также досрочно возвратить кредит.
//7.2. Передать третьему лицу права на получение Имущества по Залоговому билету и доверенности, заверенной нотариально. "
//8. ОСОБЫЕ УСЛОВИЯ
//8.1. ЗАЛОГОДАТЕЛЬ подтверждает, что данное автотранспортное средство используется исключительно в личных целях, что ему не известны права третьих лиц на закладываемое автотранспортное средство. Если ЗАЛОГОДАТЕЛЕМ, передавшим автотранспортное средство не будет сообщено о правах на это имущество третьих лиц, то он возмещает все убытки, возникшие по его вине, а также и упущенную выгоду ЗАЛОГОДЕРЖАТЕЛЯ.
//8.2. ЗАЛОГОДАТЕЛЬ гарантирует, что данное автотранспортное средство не находится в розыске, номерные агрегаты и документы автотранспортного средства не подделаны, таможенные платежи полностью уплачены, в противном случае, ЗАЛОГОДАТЕЛЬ возмещает все убытки, возникшие по его вине, а также и упущенную выгоду ЗАЛОГОДЕРЖАТЕЛЯ.
//"8.3. ЗАЛОГОДАТЕЛЬ обязан сообщить обо всех недостатках и скрытых дефектах автотранспортного средства, в противном случае он несет ответственность, установленную законодательством РФ.
//При нарушении данного пункта Договора ЗАЛОГОДЕРЖАТЕЛЬ вправе потребовать досрочного возврата суммы кредита. "
//8.4. ЗАЛОГОДЕРЖАТЕЛЬ не несет ответственность за техническое состояние заложенного АТС находящегося на хранении .
//"8.5. ЗАЛОГОДАТЕЛЬ ознакомлен и согласен с ПРАВИЛАМИ, с условиями настоящего ДОГОВОРА, описанием и оценочной стоимостью АТС, размером и сроком кредита, действующими тарифными ставками, условиями оплаты услуг, а также с тем, что хранение АТС осуществляется в Ломбарде.
//8.6. ЗАЛОГОДАТЕЛЬ ознакомлен с часами работы ЛОМБАРДА и порядком приема / выдачи денежных средств и Имущества. "
//"8.7. ДОГОВОР, Залоговый билет составлены и подписаны СТОРОНАМИ в двух экземплярах, имеющих одинаковую юридическую силу, по одному для каждой из СТОРОН. В случае утери Залогового билета ЗАЕМЩИК обязан уплатить сбор в размере 3000 рублей.
//8.8. Во всем остальном, что не оговорено настоящим ДОГОВОРОМ, СТОРОНЫ руководствуются ПРАВИЛАМИ и действующим законодательством РФ.
//8.9. Споры, возникшие между СТОРОНАМИ при исполнении настоящего договора, будут рассматриваться судом по месту нахождения ЗАЛОГОДЕРЖАТЕЛЯ. "
//"8.10. Недействительность какого-либо условия настоящего Договора не влечет за собой недействительность прочих его условий.
//8.11. На время действия настоящего договора все юридические или иные действия с автотранспортным средством и документами на него запрещены в соответствии с законодательством РФ.
//8.12. ЗАЛОГОДЕРЖАТЕЛЬ вправе потребовать досрочного исполнения обязательств, обеспеченных настоящим залогом. Основания и порядок досрочного расторжения настоящего договора: ЗАЛОГОДЕРЖАТЕЛЬ вправе досрочно взыскать задолженность по настоящему договору и / или в одностороннем порядке расторгнуть настоящий договор в случае прекращения права собственности на предмет залога, предоставленного ЗАЛОГОДАТЕЛЕМ в обеспечении настоящего договора. В случае досрочного расторжения настоящего договора и / или досрочного взыскания задолженности по настоящему договору, ЗАЛОГОДЕРЖАТЕЛЬ направляет ЗАЛОГОДАТЕЛЮ соответствующее уведомление. Корреспонденция направленная а адрес ЗАЛОГОДАТЕЛЯ и возвращенная с почтовой отметкой об отсутствии адресата, считается полученной ЗАЛОГОДАТЕЛЕМ, в случае если ЗАЛОГОДЕРЖАТЕЛЬ не был заранее уведомлен об изменении адреса ЗАЛОГОДАТЕЛЯ. "
//9. АДРЕСА, РЕКВИЗИТЫ И ПОДПИСИ СТОРОН
//ЗАЛОГОДАТЕЛЬ ЛОМБАРД
//"Зинатуллина Эльвира Тимерьяновна
//Адрес регистрации: 450ххх, Башкортостан Респ, Уфа г, ххххххх, д. нн, кв. щщ
//Адрес проживания: 450078, 450ххх, Башкортостан Респ, Уфа г, ххххххх, д. нн, кв. щщ
//ИНН:
//Паспорт гражданина Российской Федерации серия хх хх № 0хххххх выдан 1х.хх.20ххх Мечетлинским РОВД Респ. Башкортостан код подр.
//Дата рождения: 2х.хх.1986
//телефоны: СОТОВЫЙ:89174773555" "ООО ""СУПЕР ПУПЕР АВТОЛОМБАРД""
//Юридический адрес:
//ИНН: 0274999999 КПП: 027801001
//ОГРН: 1119999999999 от 15.хх.2хх1
//Расч./сч: 40701999999999999999
//ОАО ""АЛЬФА-БАНК""
//Корр./сч: 3010181010999999999
//БИК: 048079999
//"
// Директор
// ________________ /Петров П. Ю./
// М.П.

 

 

3.

 

Ниже текст дискуссии по данной отраслевой конфигурации ВДГБ ломбард (в процессе выяснения мнений разработчиков):

Попалось решение ВДГБ: Ломбард 3.3 слегка измененное. После поверхностного анализа, изучения документации по продукту на сайте техподдержки ВДГБ стало ясно и объектов конфигуратора с префикком "ЛМБ_" стало понятно, что выполнен как надстройка к Бухгалтерия Предприятия 2.0. 
Вопросы к разработчикам кто работал с подобной конфигурацией? Какие используются "надстройки" (изменения) для учета дополнительных реквизитов для специфических объектов, частности для спраовочика "залоговые вещи". Для данного справочника не хотели сохраняться доп. реквизиты, характеризующие вещь более конкретно. 
Как только полез в конфигуратор и отловил, что используется стандартная обработка Значения свойств объектов, как в типовых механизмах стандартной БП 2.0 (Планы видов характеристик "Назначения свойств, категорий объектов" и "свойства объектов" все стало сохраняться. Очевидно, была ошибка данных. Какую кто использует методику корректировки сведений залоговых вещах? 
Вопрос как пересекаются между собой типовой и механизм ВДГБ по учету дополнительных характеристик и какие 
Вижу еще кучу регистров сведений с префиксом "ЛМБ_" для учета печатных форм, в обход типового механизма внешних печатных форм БП 2.0 Тут вопрос насколько и с какой целью тут завязан подобный механизм? Для печатных форм работают обычные ВПФ, кроме отчета в конфигурации "ЛМБ_БО7" по залоговому билету. Вызов зачем-то вообще из документа "ОперацияПоЗалогу". Алгоритм печати запутан на множестве признаков: 

Если СсылкаНаДокумент.ВидОперации = Перечисления.ЛМБ_ВидыОпераций.Залог
     Или СсылкаНаДокумент.ВидОперации = Перечисления.ЛМБ_ВидыОпераций.Перезалог
     Или СсылкаНаДокумент.ВидОперации = Перечисления.ЛМБ_ВидыОпераций.ЧастичныйВыкупПерезалог Тогда
        ПоследняяОперацияЗалога  = СсылкаНаДокумент;
        ДатаЗалога = ЛМБ_ОбщегоНазначенияПереопределяемый.ПолучитьДатуЗалогаЗБ(ПоследняяОперацияЗалога);
        ДатаВыкупа = ПоследняяОперацияЗалога.ДатаВыкупа;
        ДатаОплаты = ПоследняяОперацияЗалога.ДатаВыкупа;
    Иначе
        ПоследняяОперацияЗалога  = ЛМБ_ОбщегоНазначенияПереопределяемый.ПолучитьПоследнююОперациюПоБилету(СсылкаНаДокумент.ЗалоговыйБилет, СсылкаНаДокумент.ДатаОперации, СсылкаНаДокумент, Истина);
        ДатаЗалога = ЛМБ_ОбщегоНазначенияПереопределяемый.ПолучитьДатуЗалогаЗБ(ПоследняяОперацияЗалога.ДокОперация);
        ДатаВыкупа = ПоследняяОперацияЗалога.ДатаВыкупа;
        ДатаОплаты = СсылкаНаДокумент.ДатаОперации;
    КонецЕсли;

...Показать

 

Ответили: (8)
 
3. ВДГБ Ломбард 3.3 - общий вид закладок - доработок функционала БП 2.0.jpg (30.77 КБ) [ Скачать ]
1. БДГБ Ломбард 3.3 - Документ операция по залогу.jpg (63.64 КБ) [ Скачать ]
4. ВДГБ Ломбард 3.3 - из справочника ЗалоговыеВещи для доп. рекв. исп. стандартная обработка ЗначениеСвойствОбъектов.jpg (18.28 КБ) [ Скачать ]
2. Справочник Залоговые вещи.jpg (40.34 КБ) [ Скачать ]
5. ВДГБ Ломбард 3.3 Еще специфический регистр надстройка к механизму дополнительных внешних печатных форм.jpg (25.11 КБ) [ Скачать ]
 

Еще вопрос к вышеописанному знающим людям: не предусмотрен ли без правки конфигурации фильтр дополнительных реквизитов по типу вещи, находящейся в залоге. Например, в зависимости от группы номенклатуры "автомобиль", "мобильные телефоны", "драгоценности" в форме был дополнительный фильтр по собственному списку дополнительных реквизитов (у автомобиля свои(номер двигателя, марка автомобиля), у драгметалла свои (прба, видДрагметалла, ...). Хотя, конфигурация уже снята с поддержки, но все-таки, нежелательно алгоритмы общих модулей править или вывод в форму всех реквизитов перехватывать на закладке "свойства". Так то можно и доп. регистр сведений в конфигуарцию добавить ВидыВещей. Непереодический, независимый с двумя измеренями: Залоговая вещь (для групп вещей) и ее характеристика. 
Второй вариант лезть в типовой механизм - дополнительное измерение "ГруппаЗалоговойВещи" в типовой регистр "Значения свойств объектов". Тут не нужно будет писать обработку для заполнения, но еще и правка форм. Не хотелось бы дублировать в двух местах типовой механизм. 
Может что-то предусмотрено для разделения в стандартном механизме ВДГБ?

Ответили: (8)
 
1. ВДГБ Ломбард 3.3 Вариант реализации механизма хранения доп. реквизитов в зависимости от принадлежности к группе залоговых вещей.jpg (14.68 КБ) [Скачать ]
2. Альтернативный вариант фильтрации доп характеристик залоговой вещи считаю хуже завязан на типовые механизмы.jpg (18.97 КБ) [ Скачать ]
 

Или все-таки переделка стандартной обработки ЗначенияСвойствОбъектов для заполнения по группам вещей (отдельный справочник типа Номенклатуры) для Стандартного Регистра "ЗначенияСвойствОбъектов" (Синоним Значения дополнительных реквизитов) и программная (либо в конфигураторе) фильтрация на вкладке свойства для дополнительных свойств залоговых вещей по видам. 
Еще нет поддержки записи прочих доп. свойств в справочник ЗначениясвойствОбъектов. У всех ли возникает подобная ошибка при использовании стандартной конфигурации ВДГБ Ломбард 3.3 или это уже "местные" доработки неизвестных мне лиц? 
Не хотелось бы без необходимости менять стандартные механизмы. Конфигурация судя по внешнему анализу и так еле работает. Возможно, стоит все привести к первоначальному "фабричному" виду.

3. ВДГБ Ломбард 3.3 Как выглядят свойства каждой вещи по отдельности - Для НОУТБУКА.jpg (35.49 КБ) [ Скачать ]
1. ВДГБ Ломбард 3.3 Стандартная мешанина комбинаций вещей и их дополнительных реквизитов в регистре сведений ЗначенияСвойствОбъектов.jpg (29.39 КБ) [ Скачать ]
4. ВДГБ Ломбард 3.3 Не устанавливаются значения доп. реквизитов по вспомогательному справочнику.jpg (43.99 КБ) [ Скачать ]
2. ВДГБ Ломбард 3.3 Как выглядят свойства каждой вещи по отдельности - Для АВТО.jpg (39.73 КБ) [ Скачать ]
 

Не читая всё (соответственно, не претендуя на вознаграждение): не взлетит ветка - "многабукф" и "многарисункаф".

 

Это самый лучший ответ :)

 

Да я просто спросил кто сталкивался. Попалась отраслевая конфигурация с которой я не работал. Единственное слабое место на инфостарте форум. Нужно какие-то придумывать техпредложения для дополнительной классификации по отраслевым конфигурациям. А то я когда что знаю всегда пишу.

Ответили: (7)
 
 

(6) kostyaomsk, ну обычно отраслевые, узкоспециализированные конфигурации пишутся как попало. Открываешь, видишь все криво, переделываешь. Задавать вопросы - смысла нет обычно.

Ответили: (10)
 
 

(1) kostyaomsk, 

стало понятно, что выполнен как надстройка к Бухгалтерия Предприятия 2.0. 
Вопросы к разработчикам кто работал с подобной конфигурацией?


Да сплошь и рядом такое. Полнейший подсад на разработчика. Типовой конфигурацией это не обновить (либо обновить, но с проблемами), с поддержки разработчика спрыгнуть можно будет только с большими проблемами. За компанию естественно вносит значительную паузу между выходом типового обновления и обновления для отраслевой конфы. 

(2) kostyaomsk, 
не предусмотрен ли без правки конфигурации фильтр дополнительных реквизитов по типу вещи, находящейся в залоге. Например, в зависимости от группы номенклатуры "автомобиль", "мобильные телефоны", "драгоценности" в форме был дополнительный фильтр по собственному списку дополнительных реквизитов (у автомобиля свои(номер двигателя, марка автомобиля), у драгметалла свои (прба, видДрагметалла, ...).


Сомневаюсь. С этой конфой ВДГБ не работал, но в типовом механизме такого разделения нет, не думаю, что ВДГБ дорабатывали этот момент. 

Хотя, конфигурация уже снята с поддержки, но все-таки, нежелательно алгоритмы общих модулей править или вывод в форму всех реквизитов перехватывать на закладке "свойства".


Я надеюсь, что конфа НЕ снята с поддержки, а просто включена возможность внесения изменений?

 

Это лучший ответ
 

Уже полазил по ней. Да, просто включена возможность изменений. Уже нашел как реализован ИХ механизм печатных форм и технология учета. Просто, мало ли. На всякий случай по этой конкретной конфигурации хотел уточнить детали.

 

(7) insurgut, вижу уже. Тут не разберется даже тот кто сам писал (и забыл). Думал, кто подскажет на что очень специфичное напоролся, да вот приходится самому. У всех все разное.

 

Вот решил выложить все свои наработки в публикации Доработка стандартного механизма ВПФ для отраслевой конфигурации ВДГБ: Ломбард 3.3.36.1 + сами печатные формы договоров и залогового билета.
По данной теме нашел еще одну публикацию насчет подбора вещей в залоговый билет Подбор залоговых вещей в документ "Подготовка к продаже" в конфигурации "ВДГБ: Ломбард 3".

 

Здравствуйте.

Вызов зачем-то вообще из документа "ОперацияПоЗалогу"
- от справочника залоговых билетов нужен только номер билета, вид БО-7 зависит от операции по залогу.
Алгоритм печати запутан на множестве признаков: ...
- насколько помню, это необходимо для корректного расчета дат начала начисления % за просрочку, хранение и т.п. (в зависимости от вида операции и схемы кредитования даты берутся разные).
Еще нет поддержки записи прочих доп. свойств в справочник ЗначениясвойствОбъектов. У всех ли возникает подобная ошибка при использовании стандартной конфигурации ВДГБ Ломбард 3.3 или это уже "местные" доработки неизвестных мне лиц?
- если речь про изменение значения свойства в форме вещи, то была такая ошибка на обычных формах, на управляемых в новых версиях такой ошибки не помню.

 

Ответили: (13)
+ 1 kostyaomsk; ]

(12) CSiER, все, конечно, правильно. Вот только лучше бы разработчики фирмы ВДГБ вынесли все алгоритмы расчета по процентам в общие модули. Тогда и к процедурам печати проще было бы обращаться оттуда. Но, что сделано однажды уже не переделать :(

Ключевые слова:   ВДГБ   Ломбард   ВДГБ ломбард   начисление процентов   ВПФ   Залоговый билет   договор аренды ПТС   аренда   1С ломбард   печатные формы ломбадра   модификация конфигуарции ломбард   договор ломбарда   модификация отраслевых конфигуарций   Методология работы ломбарда   документация ломбарда   документооборот ломбарда   бланки строгой отчетности   БО7   БО-7   Бланк БО-7   Залог автотранспорта   Залог ПТС   автоломбард   документация автоломбарда   автоматизация ломбарда   договора для ломбарда   Константин Юрин   программист 1С   для программиста по отраслевой конфигурации ВДГБ
Файлы для скачивания
  • 79р
    • ВДГБ_ВПФ_ДоговорЗалога.epf (22Kb)
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "договор залога".
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "договор залога". Из-за специфики конфигурации механизм обычных ВПФ не подходит (что-то считает сам документ). Встраивается в конфигурацию согласно рисункам и коду выше. Для программистов. Наработки.
    • дата загрузки: 06.08.2015 07:24:40
  • 79р
    • ВДГБ_ВПФ_ДоговорЗайма2014.epf (11Kb)
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "договор займа".
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "договор займа". Из-за специфики конфигурации механизм обычных ВПФ не подходит (что-то считает сам документ). Встраивается в конфигурацию согласно рисункам и коду выше. Для программистов. Наработки.
    • дата загрузки: 06.08.2015 07:27:45
  • 179р
    • Измененные и добавленные объекты в отраслевую конфигурацию ВДГБ ломбард 3.3.cf (310Kb)
    • Объекты модифицированные согласно публикации и вынесенные из отраслевой конфигурации без нарушения лицензионного соглашения. Доработки конфигурации ВДГБ ломбард
    • Объекты модифицированные согласно публикации и вынесенные из отраслевой конфигурации без нарушения лицензионного соглашения. Доработки конфигурации ВДГБ ломбард
    • дата загрузки: 06.08.2015 07:30:47
  • 79р
    • ТестВДГБ_Ломбард_3_3_ВПФ_ЗАЯВЛЕНИЕ_ОБ_ОТКАЗЕ.epf (11Kb)
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "заявление об отказе (забрать вещь и сразу получить расчет)".
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "заявление об отказе (забрать вещь и сразу получить расчет на нее)". Из-за специфики конфигурации механизм обычных ВПФ не подходит (что-то считает сам документ). Встраивается в конфигурацию согласно рисункам и коду выше. Для программистов. Наработки.
    • дата загрузки: 06.08.2015 07:32:43
  • 199р
    • ЛМБ_БО7.erf (24Kb)
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "Бланк-квитанция БО-7 (заполняется по данным документа "Операция по залогу" - бумага с кучей отрывных корешков и талонов - Самый главный и массовый документ
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "Бланк-квитанция БО-7 (заполняется по данным документа "Операция по залогу" - бумага с кучей отрывных корешков и талонов.
    • дата загрузки: 06.08.2015 07:54:58
  • 79р
    • ТестВДГБ_Ломбард_3_3_ВПФ_ДОГОВОР_ЗАЛОГА_ПТС.epf (11Kb)
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "договор залога ПТС (личного автотранспорта)".
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "договор залога ПТС (личного автотранспорта)".
    • дата загрузки: 06.08.2015 08:00:54
  • 59р
    • дата загрузки: 06.08.2015 08:01:41
  • 59р
    • ВДГБ_ВПФ_ЗалоговыйБилет.epf (24Kb)
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "залоговой билет" (Самая главная и часто используемая форма с указанием всех характеристик залоговой вещи и условий возврата)".
    • Печатная форма для вызова из конфигурации ВДГБ ломбард 3.3.36 "залоговой билет" (Часто используемая форма с указанием всех характеристик залоговой вещи и условий возврата)".
    • дата загрузки: 06.08.2015 08:03:35
Скачать все файлы одним архивом (426Kb)
0
    ≡ к списку разработок