Информационный поток
Задания вакансии материалы разработки сообщения форума
Яндекс-директ

Товарный чек с логотипом организации Для ред. УТ 11.1 с УТ 11.1.2 по УТ 11.1.10, для документа РТУ без использования ККТ.

  • Добавить свою разработку
 
Константин
Связаться с автором
12.07.2015 22:58:08
+2
Товарный чек с логотипом организации (поддержка старых релизов начиная с УТ 11.1.2, где нет такой возможности) для документа Реализация товаров и услуг (РТУ) без использования ККТ. Редакции с 11.1.2 по 11.1.10
Скриншоты
Описание
Полностью работоспособная внешняя печатная форма для документа РТУ типовой УТ 11.1 редакций с 11.1.2 по 11.1.10. Позволяет отразить розничные продажи у ИП документом, предназначенным для оптовых продаж БЕЗ НАЛИЧИЯ ККТ (например, при ЕНВД когда это разрешено). Упрощенный аналог печатной формы розничного документа "Чек ККМ" (без колонок НДС). Для варианта, когда в учете затруднительно открывать и закрывать кассовую смену и вводить отчет о розничных продажах или когда необходимо разрешить "штучные" розничные продажи в оптовом документе. Включена поддержка для печати логотипа организации в старых релизах из картинок в создаваемых служебных элементах номенклатуры.

На личном опыте убедился, что бывают ситуации, когда в учете нецелесообразно разделять оптовые и розничные продажи и нет смысла отражать операции документом "Чек ККМ" и "Отчет о розничных продажах". Для ситуаций, когда при оптовых реализациях возможны штучные "продажи". Например при торговле мебелью или при выдаче товара, заказанного покупателем через интернет-магазин.

Вначале немного теории о самой сути и необходимости применения товарного чека для ИП.Источник публикации:

Для чего нужен товарный чек?

Всем предпринимателям известно, что любое приобретение товара покупателем должно сопровождаться определённым документом. Как правило, этим документом является чек, который выбивается по кассе, но есть и дополнительные бланки, которые подтверждают покупку, например, товарный чек.

Реквизиты товарного чека.

Мы уже выяснили, что товарный чек не является обязательным документом, но по законодательству необходимо уметь правильно его заполнять, по всем нормам и правилам. Как оформить товарный чек? Обязательные реквизиты (см. рисунок 1):

Рисунок 1 Образец товарного чека от руки.

1. Имя документа.

2. Инициалы индивидуального предпринимателя.

3. Кроме этого необходимо написать название фирмы, если оно существует.

4. Обязательно указать идентификационный номер и номер свидетельства о регистрации фирмы.

5. В товарном чеке нужно указать адрес, где был приобретён товар.

6. Номер товарного чека пишется в специально отведённом «окне». Он отсчитывается  по периодам или каждый день.

7. Дата, когда был выдан чек.

8. На пустых графах должен быть перечислен весь приобретаемый товар (наименование), а так же его полное количество.

9. В конце подводится итог (общая сумма). Общая сумма указывается и прописью, и в числовом варианте.

10. Необходимо поставить подпись лица, который выписывал чек.

11. И, самое главное, ПЕЧАТЬ ИП (штамп). Тут уже нужно дополнительно выяснять по-законодательству нужно ли регистрировать шамп "для товарный чеков торговая точка N ". Ведь отдавать печать в торговую точку неразумно (тем более если она не одна). По поводу штампа или отдельной печати для операций продажи (типа печати "для гарантийных талонов" нужно выяснять у юристов. 

Так же могут быть дополнительные реквизиты на усмотрение самого предпринимателя.


Часто предприниматели задают вопрос, а какое должно быть оформление товарных чеков ИП? Что в нём должно быть написано? Заполнение товарного чека не составляет труда. В нём необходимо указать всю информацию о купленном товаре. Как правило, бланк специально для этого разлинован. Важно помнить, что следует аккуратно заполнять все графы, точно записывать количество товара, его стоимость и общую сумму. Если товаров слишком много, то есть два варианта, как произвести заполнение товарного чека: Заполнить разные чеки с пометкой о том, что один чек продолжает другой. При этом в следующем товарном чеке будет указана общая сумма, а не в каждом отдельном чеке. Записать товар на разные чеки с разными номерами, где будет указываться общая сумма по каждому из чеков раздельно. Ещё одна небольшая особенность товарного чека. В самом низу чека всегда есть место для печати, но не все индивидуальные предприниматели имеют печати. Для заполнения и выдачи товарных чеков печать должна быть обязательна, хотя по законодательству предпринимателю не нужно оформлять печать. Товарные чеки для ИП можно заполнять не только перечислением товаров, но и услуг, которые выполняет фирма. Услуги указываются точно так же методом перечисления, в каком объёме выполнены и какая общая сумма получается. Предприимчивые коммерсанты ведут книгу учётов товарных чеков, делают их копии. Это поможет избежать конфликтов с клиентами, а так же поможет всегда быть в курсе, когда и кем был выписан тот или иной товарный чек.   Когда используется товарный чек? Зачем он необходим? Товарный чек, как было сказано, необходим для того, чтобы указать все приобретённые товары или полученные услуги. Его часто просят выписать клиенты, которые имеют на руках подотчетные денежные средства. Грамотно и правильно заполненный товарный чек поможет избежать недоразумений с клиентами.Товарный чек не нужно заполнять при каждой продаже. Он необходим только если сам клиент просит вас заполнить документ. Следует помнить, что любой товарный чек заполняется по нормам законодательства. Часто, предприниматель ставит на товарный чек печать и подпись  и в таком виде отдаёт продавцам. Это очень ошибочное решение.Многие продавцы не знакомы с тем, как правильно заполнять такие чеки. Клиенты могут по несколько раз возвращаться и просить заполнить чек заново. Использовать ли товарные чеки или нет решать предпринимателю. Как показывает практика, лучше подстраховаться во всех тонкостях и спокойно развивать бизнес, чем расстраиваться из-за того, что нет хорошей выручки или происходят постоянные разбирательства с клиентами. Товарный чек – это второстепенный документ к основному чеку, но тоже необходимый.
Источник: http://biznes-prost.ru/o-tovarnyx-chekax-zapolnenie-vydacha.html

Еще ИП важно учесть следующее (источник):

 

Наказание за невыдачу товарного чека.

Однако, есть такие ситуации, когда продавец по какой-то причине товарный чек не выдал. Таим образом, получается, что имеет место нарушение, за которым последует наказание. Если говорить о штрафных санкциях, то для торговой организации это будет штраф в размере от 30 до 50 тысяч рублей. А вот на работников торговой организации штраф будет чуть меньше — от 3 до 4 тысяч рублей. В любом случае подобных нарушений допускать нельзя, так как налоговая инспекция, осуществляющая контроль за выдачей товарных чеков и за наличием в них всей требуемой информации, строго и тщательно отслеживает этот процесс.

 

Теперь что касается самой разработки: товарный чек для оптового документа под разные релизы УТ 11.1:

Печатная форма простая. Делалась для типового релиза УТ 11.1.10.138, но была проверена на УТ 11.1.9.51. Есть поддержка логотипа для организации.

Внимание! Для версии Товарного чека 1.0.3 сделана возможность печати логотипа из создаваемых в служебном каталоге справочника номенклатуры "ГруппаЛоготиповДляОрганизации (НЕ использовать!) для печати" элементов номенклатуры (часть названия которого содержит наименование организации для которой предназначен хранимый логотип) для хранения названия организации в файле изображения номенклатуры (реквизит справочника номенклатуры "ФайлКартинки"). Формат названия элементов следующий: "ЛОГОТИП__НЕ_ИСПОЛЬЗОВАТЬ". Придумал самый хороший вариант использования номенклатуры не по назначению :)

Код для программистов для универсальности следующий:

Процедура НайтиСоздатьНоменклатуруКартинку(ФайлКартинки, Организация)
    
    ИмяГруппыЛоготипов = "ГруппаЛоготиповДляОрганизации (НЕ использовать!) для печати";
    ИмяЛоготипа = "ЛОГОТИП_"+СокрЛП(Организация.Наименование)+"_НЕ_ИСПОЛЬЗОВАТЬ";
    ГруппаЛоготипа = Справочники.Номенклатура.НайтиПоНаименованию(ИмяГруппыЛоготипов);
    //
    Попытка
        Если ГруппаЛоготипа.Пустая() Тогда
            ГруппаЛог = Справочники.Номенклатура.СоздатьГруппу();
            ГруппаЛог.Наименование = ИмяГруппыЛоготипов;
            ГруппаЛог.Записать();
            ГруппаЛог = ГруппаЛог.Ссылка;
        КонецЕсли;
        
        Рез = Справочники.Номенклатура.НайтиПоНаименованию(ИмяЛоготипа, Истина, ГруппаЛоготипа);
        Если НЕ Рез.Пустая() Тогда
            ФайлКартинки = Рез.ФайлКартинки;
            Возврат;
        КонецЕсли;    
        
        // А если все плохо...
        НовыйЭлемент = Справочники.Номенклатура.СоздатьЭлемент();
        // Если в релизах разные реквизиты?!
        НовыйЭлемент.Родитель = ГруппаЛоготипа;
        НовыйЭлемент.Наименование = ИмяЛоготипа;
        НовыйЭлемент.НаименованиеПолное = ИмяЛоготипа;
        НовыйЭлемент.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар;
        НовыйЭлемент.ВидНоменклатуры = Справочники.ВидыНоменклатуры.НайтиПоНаименованию("Товар");
        НовыйЭлемент.ВариантОформленияПродажи = Перечисления.ВариантыОформленияПродажи.РеализацияТоваровУслуг;
        НовыйЭлемент.ГруппаДоступа = НайтиЛюбуюГруппуДоступа();
        НовыйЭлемент.ЕдиницаИзмерения = Справочники.ЕдиницыИзмерения.НайтиПоНаименованию("шт");
        НовыйЭлемент.ИспользованиеХарактеристик = Перечисления.ВариантыИспользованияХарактеристикНоменклатуры.НеИспользовать;
        НовыйЭлемент.Качество = Перечисления.ГрадацииКачества.Новый;
        НовыйЭлемент.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;
        
        Если НовыйЭлемент.ПроверитьЗаполнение() Тогда
            НовыйЭлемент.Записать();
            Ссылка = НовыйЭлемент.Ссылка;
            СказатьПользователю("Для Организации <<"+Организация+">> в каталоге <<"+ИмяГруппыЛоготипов+">> СОЗДАН элемент номенклатуры <<"+
            ИмяЛоготипа+">> - ДОБАВЬТЕ в него КАРТИНКУ - она будет Являться логотипом для Этой организации и не меняйте наименование или СОЗДАЙТЕ в этом каталоге РУКАМИ!");
            Возврат;
        Иначе
            текстОшибки = "Не смогли сохранить элемент номеклатуры где будет храниться логотип для Организации <<"+Организация+">> в каталоге <<"+ИмяГруппыЛоготипов+">> с ТАКИМ ТОЧНЫМ НАИМЕНОВАНИЕМ <<"+
            ИмяЛоготипа+">> - СОЗДАЙТЕ РУКАМИ с таким же точным названием И ДОБАВЬТЕ В НЕГО КАРТИНКУ!"; 
            СказатьПользователю(текстОшибки);
            Возврат;
        КонецЕсли;
    Исключение
        Ош = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() );
        текстОшибки = "Не смогли сохранить элемент номеклатуры где будет храниться логотип для Организации <<"+Организация+">> в каталоге <<"+ИмяГруппыЛоготипов+">> с ТАКИМ ТОЧНЫМ НАИМЕНОВАНИЕМ <<"+
        ИмяЛоготипа+">> - СОЗДАЙТЕ РУКАМИ с таким же точным названием И ДОБАВЬТЕ В НЕГО КАРТИНКУ! Подробно: "+Ош; 
        СказатьПользователю(текстОшибки);        
    КонецПопытки;
    
КонецПроцедуры

Удивительно, но заругалась только на один реквизит и одну процедуру во всех старых релизах контактная информация и прочее осталось прежним (раз везде работает - проверял).

 

Ниже привожу скриншоты для иллюстрации "новинки" для использования, начиная с древней версии УТ 11.1.2:

Как и где создаются каталог и элементы для хранения изображений в старых версиях УТ 11.1.2 (возможно и ранее нет конфигурации 11.1.0) до версии УТ 11.1, где уже присутствует реквизит сравочника Организации "ФайлКартинки" и есть похожие срества для вставки логотипа.

 Вывод сообщения при первом запуске обработки печати о созданых элементах, в которые уже необходимо добавить самим необходимую информацию.

Общий вид печати без логотипа с выводом служебных сообщений при первом запуске в старой конфигурации УТ 11.1

Что касается предметной области с удовольствием послушаю аргументированное мнение о целесообразности ведения подобного учета (нарисовал по просьбе заказчика). За Ваши деньги любой каприз :)


Далее привожу как использовать на релизах УТ 11.1.9 и выше:


Ниже источник данных документ РТУ, способы добавления логотипа (файл jpeg и прочая графика в базу УТ 11.1.хх) и внешний вид при выводе на печать данной ВПФ.

 

 

 

 Надеюсь, данная ВПФ будет полезна.
Ключевые слова:   Товарный чек   Управление торговлей   торговля   Чек ККМ   Чек   ВПФ   внешняя печатная форма   УТ 11.1   УТ 11.1.9   УТ 11.1.10   логотип организации   печать   чек   ВПФ тованый чек   печаная форма с логотипом организации   товарный знак.
Файлы для скачивания
  • 499р
    • ТоварныйЧекДляУТ_11_1_Редаксии_с_11.1.2_По_11.1.10.epf (19Kb)
    • Товарный чек с логотипом организации для документа Реализация товаров и услуг (РТУ) типовой Управление торговлей 11.1.Х (редакции с 11.1.2 по 11.1.10) планируется с 11.1.0 по 11.2
    • Полностью работоспособная внешняя печатная форма для документа Реализация товаров и услуг (оптовый документ РТУ) для типовой УТ 11.1 редакции управление торговлей с 11.1.2 по 11.1.10 (с 11.1.0 по УТ 11.2 планируется доработка и поддержка с сентября 2015 г.) позволяет отразить розничные продажи документом, предназначенным для оптовых продаж. Упрощенный аналог печатной формы розничного документа "ЧекККМ" (без колонок НДС для ИП на ЕНВД). Для варианта, когда в учете затруднительно открывать и закрывать кассовую смену и вводить отчет о розничных продажах или когда необходимо разрешить "штучные" розничные продажи в оптовом документе.
    • дата загрузки: 12.07.2015 22:59:23
0
    ≡ к списку разработок