Информационный поток
Задания вакансии материалы разработки сообщения форума
Яндекс-директ

Вспомогательные формы для ввода числа даты (для сенсорных экранов)

  • Добавить свою разработку
 
Елена
Связаться с автором
05.08.2014 08:49:23
0
Используется в обработчиках реквизитов, где вместо стандартных калькулятора и календаря от 1С, нужно открыть "большой" калькулятор и календарь "под палец".
Описание

В колонке "Количество" на событие "НачалоВыбора" пишем обработчик:

 

&НаКлиенте
Процедура ТоварыКоличествоУпаковокНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    
    ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
    Если ТекущиеДанные = Неопределено Тогда
        Возврат
    КонецЕсли;
    
    ТекКоличество = _ВвестиЗначение(ТекущиеДанные.КоличествоУпаковок);
    Если ТекКоличество <> 0 Тогда
        ТекущиеДанные.КоличествоУпаковок = ТекКоличество;
        
        ТоварыКоличествоУпаковокПриИзменении(ТекущиеДанные);
    КонецЕсли;
КонецПроцедуры

 

//Функция _ВвестиЗначение() обращается к общему модулю, где вызывается внешняя обработка:

 

&НаКлиенте
Функция _ВвестиЗначение(Значение)     
   Возврат ВнешниеФункцииКлиент.ВводЧислаДаты(Значение, ЭтаФорма)   
КонецФункции  

 

//общий модуль

 

Функция ВводЧислаДаты(Значение, ВладелецФормы) Экспорт
    
    Если ТипЗнч(Значение) = Тип("Дата") Тогда
        
        ИмяФормы = "ФормаКалендаря";
        
    Иначе //число
        
        ИмяФормы = "ФормаВводЧисла"; 
        
    КонецЕсли;    
        
    Параметры = Новый Структура("Значение", ?(ЗначениеЗаполнено(Значение), Значение, ""));
        
    ИмяОбработки = ВнешниеФункцииКлиентПовтИсп.ПодключитьОбработкуФормы("Ввод числа или даты");
    ФормаОбработки = ПолучитьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма." + ИмяФормы, Параметры, ВладелецФормы);
    ФормаОбработки.ОткрытьМодально();
    
    Возврат ФормаОбработки.ВыбранноеЗначение;
    
КонецФункции

 

Ключевые слова:   внешняя обработка   РМК   кнопки. сенсорный экран
Файлы для скачивания
0
    ≡ к списку разработок