Информационный поток
Задания вакансии материалы разработки сообщения форума
Яндекс-директ

Выбор периода для управляемых форм

  • Добавить свою разработку
 
Зубарев Денис Александрович
Связаться с автором
26.06.2014 09:02:24
0
Форма выбора стандартного периода для управляемых форм
Скриншоты
Описание

Форма выбора стандартного периода для управляемых форм.

 

Пример(8.3 интерфейс такси):

 

На любой форме добавляем кнопку.

в команде кнопки прописываем:

 

&НаКлиенте
Процедура ВыбратьПериод(Команда)

         ОписаниеОповещения = Новый ОписаниеОповещения("РезультатВыбораПериода",ЭтотОбъект);
         ОткрытьФорму("ОбщаяФорма.ФормаВыбораПериода",,,,,,ОписаниеОповещения);

КонецПроцедуры

 

&НаКлиенте
Процедура РезультатВыбораПериода(Результат, ДополнительныеПараметры) Экспорт

         Если Результат <> Неопределено Тогда
                  ЭтотОбъект.ДатаНачала = Результат.ДатаНачала;
                  ЭтотОбъект.ДатаОкончания = Результат.ДатаОкончания;
         КонецЕсли;

КонецПроцедуры

Ключевые слова:   Форма выбора периода
Файлы для скачивания
0
    ≡ к списку разработок