Информационный поток
Задания вакансии материалы разработки сообщения форума
Рубрики статей и материалов
Яндекс-директ

Windows Server 2012 RDP и 1С. Удаленное подключение к пользователям (теневая копия)

  • Добавить свою публикацию
  • для этого требуется регистрация

Пример обработки для запуска команды удаленного подключения к пользователям(теневая копия) Windows 2012 Server из 1С.

 

Получить(обновить) список пользователей:

 

&НаКлиенте
Процедура ОбновитьСписокПользователей()
ТЗПользователи.Очистить();
КомандаСистемы("query user> C:1C1.txt");

Файл = Новый ЧтениеТекста("C:1C1.txt", КодировкаТекста.OEM);
Стр = Файл.ПрочитатьСтроку();
Пока Стр <> Неопределено Цикл
СтрТЗ = ТЗПользователи.Добавить();
СтрТЗ.Логин = Сред(Стр, 2,6);
СтрТЗ.ID = Сред(Стр, 42,3);
СтрТЗ.Статус = Сред(Стр, 47,8);
Стр = Файл.ПрочитатьСтроку();
КонецЦикла;
КонецПроцедуры

 

Подключение к сеансу пользователя :

 

 

&НаКлиенте
Процедура ТЗПользователиВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;

Если ТипЗнч(ВыбраннаяСтрока) = Тип("СтрокаГруппировкиДинамическогоСписка") Тогда
Возврат;
КонецЕсли;
КомандаСистемы("powershell start-process mstsc -argumentlist '/shadow:"+Элемент.ТекущиеДанные.ID+" /control' -verb runAs");
//где "Элемент.ТекущиеДанные.ID" - ID сеанса
//runas /user:pl-tsАдминистратор /savecred mstsc -- запуск под пользователям и сохранение пароля
//powershell start-process cmd -verb runAs -- запуск из под администратора с запросом выполнения
//"mstsc /shadow:"+Элемент.ТекущиеДанные.ID+" /noConsentPrompt" -- mstsc с параметрами
//powershell start-process mstsc -argumentlist '/shadow:10 /noConsentPrompt' -verb runAs
КонецПроцедуры

 

 

 
0
≡ к списку статей