Информационный поток
Задания вакансии материалы разработки сообщения форума
Рубрики статей и материалов
Яндекс-директ

Выполнение запроса в общем модуле

  • Добавить свою публикацию
  • для этого требуется регистрация

Устали писать

 

Запрос = Новый Запрос;

Запрос.УстановитьПараметр(…

Рез = Запрос.ВыполнитьПакет(); 

?

Есть решение – вынести выполнение запроса в функцию общего модуля!

Что это означает?

Передаём этой функции текст запроса и параметры. Получаем от неё результат выполнения запроса.

Зачем?

1.При разработке больше не требуется повторять установку массы параметров – достаточно сформировать структуру. Код функции сам сделает ‘Запрос.УстановитьПараметр(’.

2.Можно передать текст, например, сохранённый в регистре сведений. Или в макете. Или в текстовом файле. Или введённый вручную.

3.Обрабатываем и пакеты и единичные запросы.

Что нужно сделать?

Используем модуль, выполняемый на сервере. Вызов с клиента не важен, поскольку всё равно возвращаемое значение  не сможет быть обработано на клиенте.

Изображение 

 

Пишем код:

 

Функция
ПолучитьРезультатВыполненияЗапроса(ТекстЗапроса,
структПараметров = Неопределено)
Экспорт

		    Запрос = Новый Запрос;

		    Если Не структПараметров =
Неопределено Тогда

				   Для Каждого КлючЗначение Из структПараметров Цикл

						   Запрос.УстановитьПараметр(СокрЛП(КлючЗначение.Ключ), КлючЗначение.Значение);

				   КонецЦикла;

		    КонецЕсли;

		    Запрос.Текст = ТекстЗапроса;

		    Рез = Запрос.ВыполнитьПакет();

		    Возврат Рез[Рез.ВГраница()];

КонецФункции 

Вызов можно осуществить, например, так

Изображение 

В структуру собираются параметры. Соответственно, если нужно сформировать запрос без параметров, то ничего не передаём – в функции значение по умолчанию неопределенно.

 
0
Читайте также
(V 7.7) Справка по работе с метаданными (с примерами)
Получение метаданных в программе 1С 7.7 происходит через объект "Метаданные"
Внимание! Будь осторожен - "макет" возможен.
В 1С 8 есть полезная возможность сохранять в качестве макета сторонние файлы
Консоль компоновки данных
Обработка для анализа данных , отладки запросов, написания отчетов без конфигуратора - предназанчена для программистов и продвинутых пользователей
Разработки
Универсальная замена значений для ЛЮБОЙ конфигурации
Замена объектов на новые или перенос данных по счету
Консоль компоновки данных
Обработка состоит их запросов, СКД и объектов
Аудит компьютеров и программного обеспечения
Конфигурация отслеживает программное обеспечение
≡ к списку статей