Информационный поток
Задания вакансии материалы разработки сообщения форума
Рубрики статей и материалов
Яндекс-директ

Чтение файла на сервере в режиме управляемого приложения 1С:Предприятие 8.*

  • Добавить свою публикацию
  • для этого требуется регистрация

При работе с файлами в режиме управляемого приложение необходимо иметь ввиду, что выполнить какие-либо действия с данными файла нужно на сервере (например создать и заполнить элемент справочника), а сам файл доступен на клиенте. Т.о. необходимо либо считать данные файла в массив информации и в обрабатывать его на сервере или передать файл на сервер. В статье описан второй способ.

 

Задача: Заполнить справочник из файла в режиме управляемого приложения 1С.

Необходимо выполнить несколько этапов:
1) Поместить файл во временное хранилище

 

&НаКлиенте
Процедура ЗагрузитьСДиска(Команда)
    АдресВХранилище = "";
    ВыбранноеИмяФайла = "";
    Если ПоместитьФайл(АдресВХранилище,,ВыбранноеИмяФайла,,УникальныйИдентификатор) Тогда
        Файл = Новый Файл(ВыбранноеИмяФайла);
        Объект.СсылкаНаФайлВоВременномХранилище = АдресВХранилище;
		ЗагрузитьВСправочник();
    КонецЕсли;    
КонецПроцедуры

 2) Непосредственная загрузка в справочник. Из временного хранилища создадим временный файл и прочитаем его

&НаСервере
Процедура ЗагрузитьВСправочник()
    ДвоичныеДанные = ПолучитьИзВременногоХранилища(Объект.СсылкаНаФайлВоВременномХранилище);
    ИмяВременногоФайла = ПолучитьИмяВременногоФайла("txt");
    ДвоичныеДанные.Записать(ИмяВременногоФайла);
    Текст = Новый ЧтениеТекста(ИмяВременногоФайла);
    Стр = Текст.ПрочитатьСтроку();
	Пока Стр <> Неопределено Цикл 
		 //код обработки строки, например создание и заполнение элемента справочника
		 Стр = Текст.ПрочитатьСтроку();
	КонецЦикла;

    Текст.Закрыть();
    УдалитьФайлы(ИмяВременногоФайла);

КонецПроцедуры

 

 
0
≡ к списку статей