Информационный поток
Задания вакансии материалы разработки сообщения форума
Рубрики статей и материалов
Яндекс-директ

Подключение КЛАДР к своей конфигурции

  • Добавить свою публикацию
  • для этого требуется регистрация

За основу возьмем конфигурацию БП 2.0 (перенесем из нее Регистр Сведений "Адресный Классификатор").

 

Вообще для работы Адресного Классификатора (Форма списка, Загрузки)достаточно перенести в нашу конфигурацию лишь АдресныйКлассификаторОбщие модули "УправлениеКонтактнойИнформацией" "ПроцедурыПоискаПоСтроке" и Формы "ХодВыполненияОбработкиДанных" (для загрузки Кладр)

Изображение


и позаимствовать некоторые процедуры и функции:

В форме списка «АдресныйКлассификатор» в процедуре «Процедура ПриОткрытии()» вносим изменения добавляем функцию

"ЕстьЗаписиВРегистреСведений" Из Общие модули"Полные права" следующим образом:

 

  Функция ЕстьЗаписиВРегистреСведений(ИмяРегистра)

    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ ПЕРВЫЕ 1
 | РегСв.*
 |ИЗ
 | РегистрСведений." + ИмяРегистра + " КАК РегСв";
    
    Возврат НЕ Запрос.Выполнить().Пустой();

КонецФункции;

Процедура ПриОткрытии()
    
    //Если НЕ ПолныеПрава.ЕстьЗаписиВРегистреСведений("АдресныйКлассификатор") Тогда
    Если НЕ ЕстьЗаписиВРегистреСведений("АдресныйКлассификатор") Тогда
        ОтветНаВопрос = Вопрос("Адресный классификатор пуст. Хотите произвести загрузку адресного классификатора?", РежимДиалогаВопрос.ДаНет);
        Если ОтветНаВопрос = КодВозвратаДиалога.Да Тогда
            РегистрыСведений.АдресныйКлассификатор.ПолучитьФорму("ФормаЗагрузкиАдресногоКлассификатора").Открыть();
        КонецЕсли;
    КонецЕсли;
    
КонецПроцедуры;


 

Переносим процедуры и функции из общих модулей "ОбщегоНазначения" и "РегламентированнаяОтчетность" в модуль "УправлениеКонтактнойИнформацией"

Из "ОбщегоНазначения» : Функция «РазложитьСтрокуВМассивПодстрок» Функция «ТолькоЦифрыВСтроке» Функция «СформироватьТекстСообщения» Процедура «СообщитьОбОшибке»

Из «РегламентированнаяОтчетность» Функция «РазложитьАдрес»

И меняем соответственно во всех местах модуля

Изображение

Вот и всё теперь в нашей новой конфигурации есть Адресный классификатор с рабочей загрузкой КЛАДР.

Изображение

Изображение

 

Изображение

Если оставлять существующую форму выбора в Адресном Классификаторе и пользоваться ей, потребуются еще дополнительные модули:

Регистры Сведений "КонтактнаяИнформация"

Обработки "РедактированиеКонтактнойИнформации"

Перечисления  "ТипыКонтактнойИнформации" и "ВидыОбъектовКонтактнойИнформации"

Справочники "АдресныеСокращения" и "ВидыКонтактнойИнформации"

Общие модули  "РаботаСДиалогами" "ОбщегоНазначения" "МеханизмНумерацииОбъектов"

У меня получилось Следующее:(Справочник Контрагенты создан(не копировался))

Изображение

Изображение

 
0
Читайте также
Подчиненные справочники. Быстро.
Создание подчиненных справочников
Доработка документа Перечисление НДФЛ в бюджет РФ
"Удобная форма для подбора платежного поручения в документе перечисление НДФЛ в бюджет РФ"
Разработки
3-НДФЛ для ЗУПа
ЗУП отчет 3-НДФЛ по сотрудникам
Запонтить строки документа "По Образцу"
Возможность заполнить строки документа
Поиск повторяющихся элементов справочников. ДЛЯ ЛЮБОЙ КОНФИГУРАЦИИ 7.7
Обработка для поиска дубляжей элементов справочников для 1С7.7(любой)
Еще от автора
≡ к списку статей