Информационный поток
Задания вакансии материалы разработки сообщения форума
Рубрики статей и материалов
Яндекс-директ

Отключение Техподдержки

  • Добавить свою публикацию
  • для этого требуется регистрация

Создаём  обработку,в ней кнопку 

Изображение

а в этой кнопке пишем: 

 

 
Процедура КнопкаВыполнитьНажатие(Кнопка)
	ПользователиБазы = ПользователиИнформационнойБазы.ПолучитьПользователей();
	Если ПользователиБазы.Количество()>0 тогда
	   Для Каждого Пользователь Из ПользователиБазы Цикл
	      ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь, , Пользователь.Имя);
		  ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь , Пользователь.Имя);
	      Сообщить("Для пользователя " + Пользователь.Имя + " интернет-поддержка отключена");
	  КонецЦикла;
  Иначе
	  ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь);
	  ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь);
      Сообщить("Интернет-поддержка отключена");
	КонецЕсли;
КонецПроцедуры

 

 

После сохраняем,открываем внешне жмём на кнопку и вуаля..напоминание нас больше не тревожит.

 

 
0
Еще от автора
≡ к списку статей